Closed Bug 1598425 Opened 5 years ago Closed 4 years ago

Crash in [@ mozilla::layers::CreateTextureData]

Categories

(Core :: Graphics, defect, P1)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox-esr68 --- disabled
firefox72 --- disabled
firefox73 --- disabled
firefox74 --- disabled
firefox75 --- fixed

People

(Reporter: marcia, Assigned: bobowen)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-38c97f79-abd7-4090-b1cf-a732f0191030.

Seen while looking at nightly crash stats - relatively small volume Win only crash which started in 20191029093803: https://bit.ly/33eJSiY

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9277be3613ca5109ae4007a512ee75856f8f1120&tochange=25bf8e097e604cca2842af6754c2c1698db5618a

All have MOZ_CRASH(Failed to create TextureData.)

Bug 1582372 touched code in this area. ni on :bobowen

Top 10 frames of crashing thread:

0 xul.dll static class mozilla::layers::TextureData* mozilla::layers::CreateTextureData gfx/layers/CanvasTranslator.cpp:46
1 xul.dll mozilla::layers::CanvasTranslator::Init gfx/layers/CanvasTranslator.cpp:72
2 xul.dll mozilla::layers::CanvasParent::RecvInitTranslator gfx/layers/ipc/CanvasParent.cpp:158
3 xul.dll mozilla::layers::PCanvasParent::OnMessageReceived ipc/ipdl/PCanvasParent.cpp:137
4 xul.dll mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2130
5 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:2003
6 xul.dll MessageLoop::DoWork ipc/chromium/src/base/message_loop.cc:523
7 xul.dll base::MessagePumpDefault::Run ipc/chromium/src/base/message_pump_default.cc:35
8 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
9 xul.dll MessageLoop::Run ipc/chromium/src/base/message_loop.cc:290

Flags: needinfo?(bobowencode)

Thanks Marcia, I'll be looking into this.

Assignee: nobody → bobowencode
Status: NEW → ASSIGNED
Flags: needinfo?(bobowencode)
Priority: -- → P1

:bobowen, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(bobowencode)
Flags: needinfo?(bobowencode)
Regressed by: canvas-ipc

These nearly all appear to be either device resets or OOMs, with one invalid size.
Crashing is clearly too aggressive here.
I think it should:

  • make sure the reset has been reported, if there is one
  • probably add a critical note
  • return null
  • check for null in the callers and in the normal case add a null surface descriptor against the content DrawTarget pointer
  • handle the null descriptor when retrieved on the Compositor thread

This should be fixed by patches in bug 1598585.

Depends on: 1598585

This should have been fixed by bug 1598585.

Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.