[RFE] Bookmark Menu should not close when you drop an item in it.

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: shadytrees, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020721
BuildID:    2002072104

When you want to move an item in Bookmarks but don't want to go to the Bookmark
Manager, you can drag and drop the item in Bookmark Menu from the Personal
Toolbar. However if you do this, it will auto close after you drop the item.

Reproducible: Always
Steps to Reproduce:
1.Open the Bookmark Menu from the Personal Toolbar.
2.Drag and Drop an item.
3.The Menu closes.

Actual Results:  The Bookmark Menu closes.

Expected Results:  The Bookmark Menu should have stayed open awaiting your next
move.

Comment 1

16 years ago
Same on WinMe with trunks 2002070504 and 2002072718, but I figured it wasn't
that important till bug 19437 was fixed.

This should go to Bookmarks instead of Browser-General.
Blocks: 133604

Comment 2

16 years ago
*** Bug 19922 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
-> bookmarks
Assignee: Matti → ben
Status: UNCONFIRMED → NEW
Component: Browser-General → Bookmarks
Ever confirmed: true
QA Contact: asa → claudius

Comment 4

16 years ago
The old behavior was to stick the menu if it was open before the drag.
With the new code for DND, it may not be that easy to implement in a proper way.
Let's see if many people want that.
Severity: normal → minor
Keywords: regression
OS: Windows 98 → All
Hardware: PC → All
Summary: Bookmark Menu auto closes if you drag&drop item → [RFE] Bookmark Menu should not close if you drop an item in it.

Comment 5

16 years ago
This WFM with trunk 2002080718 and the patch from bug 114962 on WinME. When I
open the Bookmark Menu (any), I can rearrange items without the menu closing
after the drop. Would be nice if it scrolled while dragging too, though.

Updated

16 years ago
URL: N/A
Summary: [RFE] Bookmark Menu should not close if you drop an item in it. → [RFE] Bookmark Menu should not close when you drop an item in it.

Comment 6

16 years ago
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: minor → enhancement
Product: Browser → Seamonkey

Comment 7

12 years ago
*** Bug 231098 has been marked as a duplicate of this bug. ***
Assignee: bugs → nobody
QA Contact: claudius → bookmarks
The bookmark menu doesn't close with SM trunk -> wfm
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.