Closed Bug 114962 Opened 23 years ago Closed 21 years ago

[FIX] Bookmarks menu in menubar should open when link is dragged over it.

Categories

(SeaMonkey :: Bookmarks & History, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.4beta

People

(Reporter: ch-bugz, Assigned: p_ch)

References

Details

Attachments

(1 file, 1 obsolete file)

Also see Bug 100479 and Bug 30861
If the Personal Toolbar is closed the user must now have either Bookmark Manager
opened or the Sidebar bookmarks opened to drag/drop bookmarks.  

The "Bookmark" menu item should open and allow the filing of a bookmark when a
link is dragged on top of it.  This action is allowed in IE with its "Favorites"
menu item.
This is a dupe, but my headache is preventing me from searching for the other bug.
Whiteboard: DUPEME
I think the dup is bug 19437
Guess I didn't search hard enough.
Duplicate of BUG 19437

*** This bug has been marked as a duplicate of 19437 ***
Status: UNCONFIRMED → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
*** Bug 130360 has been marked as a duplicate of this bug. ***
*** Bug 135917 has been marked as a duplicate of this bug. ***
*** Bug 141292 has been marked as a duplicate of this bug. ***
This bug could be fixed without fixing bug 19437, and parts of 19437 could be
fixed without fixing this bug.
Blocks: 19437
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Bookmark file menu should open when link is dragged over it. → Bookmarks menu should open when link is dragged over it.
Whiteboard: DUPEME
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Bookmarks menu should open when link is dragged over it. → Bookmarks menu in menubar should open when link is dragged over it.
I tried this in my navigatorOverlay.xul, it gives me a drop target but the menu
won't open on drag :/

    <menu id="BookmarksMenu" label="&bookmarksMenu.label;"
accesskey="&bookmarksMenu.accesskey;" 
          datasources="rdf:bookmarks rdf:files rdf:localsearch rdf:internetsearch" 
          ref="NC:BookmarksRoot" container="true" flags="dont-test-empty" 
          template="bookmarksMenuTemplate"
          oncommand="OpenBookmarkURL(event.target, this.database)" 
          ondragdrop="nsDragAndDrop.drop(event, personalToolbarDNDObserver);
event.preventBubble()"
          ondragenter="nsDragAndDrop.dragEnter(event,
personalToolbarDNDObserver); event.preventBubble()"
          ondragexit="nsDragAndDrop.dragExit(event, personalToolbarDNDObserver);
event.preventBubble()"
          ondragover="nsDragAndDrop.dragOver(event, personalToolbarDNDObserver);
event.preventBubble()">

not even when I replaced the last line with

          ondragover="nsDragAndDrop.dragOver(event, personalToolbarDNDObserver);
OpenBookmarkURL(event.target, this.database); var toolbar =
document.getElementById('main-menubar');
toolbar.setAttribute('dd-triggerrepaint', 0)">

Using trunk build 2002072718 on Windows ME.
taking
Assignee: pchen → chanial
No longer blocks: 19437
Status: NEW → ASSIGNED
Attached patch Patch v1.0 (obsolete) — Splinter Review
I refactored and generalized a little navigatorDD.js in order that if other
persons want to use that code in another place, it will be straightforward
(doing CT's modifs and adding an observer in
personalToolbarDNDObserver.mObservers) for them. 
I also have in mind to xblify it, but not in a near future.
Current patch drops the handling of the bookmark button in the personal
toolbar. If it's too early, let me know.
r/sr?
Summary: Bookmarks menu in menubar should open when link is dragged over it. → [FIX] Bookmarks menu in menubar should open when link is dragged over it.
I have left a dump and I also modify isPlatFormSupported because I am under linux.
Ignore that.
Aside from the occasional (seperate) onDragExit bug bites. The patch works
great, I can even drag between the menubar and toolbar menus. =)
Shortcuts dragged from my desktop open the menubar's Bookmarks menu but not the
bookmarks toolbar's items. Dunno if that happened before though, and the only
places they get accepted are the content area and the sidebar Bookmarks tab
(though the shortcut to http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/
doesn't get a title).
Attached patch Patch v1.1Splinter Review
Removed the parts that should not be checked in.
I also fixed a glitch introduced by my last patch: the feedback line on the
personal toolbar was not removed when dropping in the empty space.
Attachment #94351 - Attachment is obsolete: true
Maybe I hand-patched something wrong, but I just noticed that when I drag a link
over the PT bookmarks menu, multiple subfolders can be open at once while the
menubar bookmarks menu works fine. Also, after rearranging some bookmarks in the
root level of each, I can't drag anything into the bookmark menu's subfolders
anymore apparantly due to the feedback line not going away when hovering over a
folder.

Trunk 2002080718 on WinME with Pinball and Classic themes at 1024x768.
*** Bug 164662 has been marked as a duplicate of this bug. ***
Blocks: 164421
I'm seeing the same bugs as described in comment #15 using a fresh install of
the 1.3 release and a new profile (save for bookmarks & cookie files). Same with
the February 16(not quite sure) 2003 trunk build I had before...
Blocks: 196756
fix is in the bookmark branch
No longer blocks: 196756
Target Milestone: --- → mozilla1.4beta
Blocks: 196756
Sorry, after some more testing I found it's only the rearranging bug that's
still there. Some occasional unclosed subfolders (dragexit?) confused me.
Blocks: 160019
The bookmarks branch has landed.
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago22 years ago
Resolution: --- → FIXED
This issue has been resolved on both Windows(2003-03-26-08) and Linux
(2003-03-26-12) trunk builds. However, this isn't working on the latest Macho OS
X trunk build (2003-03-25-03). Dragging a url proxy to the Bookmarks menu
doesn't cause the menu list to drop down. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Chris, having it working on MacOS would require a lot of new work since the Mac
toolbar is not handled the same way as the xp one and would need another bug.
Furtermore, I am not sure if such behavior would fit with the Mac UI guide lines.
Status: REOPENED → RESOLVED
Closed: 22 years ago21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
No longer blocks: 164421
Blocks: 158464
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: