Closed Bug 1598735 Opened 5 months ago Closed 2 months ago

Incorrect rendering when combining -webkit-background-clip:text with background-attachment:fixed

Categories

(Core :: Web Painting, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1313757

People

(Reporter: mstange, Unassigned)

References

Details

Attachments

(2 files)

Attached file testcase 1

Steps to reproduce:

  1. Load the attached testcase.
  2. Scroll down slowly.

Expected results:
The text should move upwards as usual.

Actual results:
The text stays fixed and gets partially clipped.

This happens both with and without WebRender.

This bug was reported on https://twitter.com/LeaVerou/status/1197609676495622147 .

Regression range:

  • Last good: 2016-04-15 changeset: afd82f887093e5e9e4015115ca5795ec82a6f732
  • First bad: 2016-04-16 changeset: a5322c766f510d2a6544b519ffcc72a19879c779
  • Pushlog URL
  • Potential regressor: 1263516 looks like the potential culprit

An additional note is that on builds previous to the push, the container for the text was all black.

The priority flag is not set for this bug.
:mattwoodrow, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(matt.woodrow)

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Flags: needinfo?(matt.woodrow)
Priority: -- → P3
Attachment #9110932 - Attachment description: fixed-background-clip-text.html → testcase 1
Attached file testcase 2

Just ran into this when diagnosing a webcompat.com issue (https://webcompat.com/issues/47689 ) -- attaching my reduced testcase, which is slightly different from the original & helps you visualize the bug a bit clearer perhaps:

  • my testcase doesn't use transparent text, so the actual text (lime) & the clipped-background (red) can be visualized separately.
  • my testcase adds a border, which makes it clearer that artifacts do get cleaned up when they're outside the border-area (that's why the text starts to get "eaten" from the bottom in the original testcase).

This is not really a regression; it's just a bug in the implementation of background-clip:text, it seems (which was broken at least as far back as when it was preffed on).

--> removing regression keyword & adding association with bug 759568.

Blocks: 759568
Keywords: regression

Dupe of bug 1313757, afaics.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1313757
You need to log in before you can comment on or make changes to this bug.