Closed Bug 1599495 Opened 10 months ago Closed 10 months ago

Fission preferences have additional quotation marks around their names

Categories

(Testing :: AWSY, defect)

defect
Not set
normal

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: marauder, Assigned: marauder)

References

Details

Attachments

(1 file)

While working on "Fission for awsy task", i found that there are some issues on Mac OS X, when using the marionette.get_pref() for "fission.autostart=true" pref.
The value returned is always False and it seems that this is caused by some extra quotes.

More details here:
https://phabricator.services.mozilla.com/D48660#1657547
if self.marionette.get_pref('fission.autostart') or
self.marionette.get_pref('"fission.autostart"'):
self._extra_opts.append("fission-enabled")

I did a push to try
https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=278192169&revision=4bf7c89c2b5740c0c26f0f23b49c76db4022c93d

with the patch from https://phabricator.services.mozilla.com/D48660
and i added these lines:

print('------------->>>>> Marionette prefs')
print(self.marionette.get_pref('fission.autostart'))
print(self.marionette.get_pref("fission.autostart"))
print(self.marionette.get_pref('"fission.autostart"'))
print(self.marionette.get_pref("'fission.autostart'"))

In the logs for the fission job on Mac OS X, where fission.autostart=true we have these values for the print statements above:

INFO - ------------->>>>> Marionette prefs
INFO - False
INFO - False
INFO - None
INFO - None

This is affecting the names of the subtests that appear under Performance Tab
https://treeherder.mozilla.org/#/jobs?repo=try&selectedJob=278192169&revision=4bf7c89c2b5740c0c26f0f23b49c76db4022c93d

where we have
Perfherder:
Explicit Memory opt stylo tp6: 532111348.16
Heap Unclassified opt stylo tp6: 131473216.43
Images opt stylo tp6: 7797373.46
JS opt stylo tp6: 199633608.83
Resident Memory opt stylo tp6: 558282068.06

But it should be :
Perfherder:
Explicit Memory fission-enabled opt stylo tp6: 532111348.16
Heap Unclassified fission-enabled opt stylo tp6: 131473216.43
Images fission-enabled opt stylo tp6: 7797373.46
JS fission-enabled opt stylo tp6: 199633608.83
Resident Memory fission-enabled opt stylo tp6: 558282068.06

Hi Henrik,
Can you assign this ticket to someone to look into it ?
Thanks!

Flags: needinfo?(hskupin)
Summary: Incorrect marionette.get_pref behavior → Incorrect marionette.get_pref() behavior

No, this is not a Marionette problem given that we basically use the core implementation of Services.prefs for that but a problem with the awsy task generation. Check the log for the following output earlier on:

[task 2019-11-26T09:44:52.717Z] 09:44:52     INFO -  'extra_prefs': ('"fission.autostart=true"',
[task 2019-11-26T09:44:52.717Z] 09:44:52     INFO -                  '"dom.serviceWorkers.parent_intercept=true"',
[task 2019-11-26T09:44:52.717Z] 09:44:52     INFO -                  '"browser.tabs.documentchannel=true"',
[task 2019-11-26T09:44:52.717Z] 09:44:52     INFO -                  'media.peerconnection.mtransport_process=false',
[task 2019-11-26T09:44:52.717Z] 09:44:52     INFO -                  'network.process.enabled=false'),

You can clearly see that 3 preferences are getting set with additional quotation marks in their name.

Component: Marionette → AWSY
Flags: needinfo?(hskupin)
Summary: Incorrect marionette.get_pref() behavior → For AWSY tests several preferences have additional quotation marks around their name
Assignee: nobody → marian.raiciof
Status: NEW → ASSIGNED
See Also: → 1567122

Thanks Henrik, I'll look into it.

It seems that the issue was caused by
https://searchfox.org/mozilla-central/rev/cce8b90aece0f42e5025e45282de16066eeaa662/taskcluster/taskgraph/transforms/tests.py#166-168

I removed those extra quotes to have something like:
'extra-options': ['--setpref=fission.autostart=true', ........

And i did a push to try while working on "Enable Fission for Raptor" task:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9bf2e5207aa3d749ccb622e4be8572084d300747&selectedJob=278420870

The logs are cleaner and the fission-enabled appears in subtest names under the Performance Tab.

INFO - u'extra_prefs': ('fission.autostart=true',
INFO - 'dom.serviceWorkers.parent_intercept=true',
INFO - 'browser.tabs.documentchannel=true'),

I'll upload the patch.

This was causing false results when using marionette.get_pref() method

Summary: For AWSY tests several preferences have additional quotation marks around their name → Fission preferences have additional quotation marks around their names
Pushed by mraiciof@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ae168f36163
Fission preferences have additional quotation marks r=perftest-reviewers,rwood,stephendonner
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.