Closed Bug 1600141 Opened 3 months ago Closed 3 months ago

Incorrect background color when using a border-radius between 0px and 1px

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox-esr68 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- fixed
firefox73 --- verified

People

(Reporter: mstange, Assigned: gw)

References

(Regression)

Details

(Keywords: correctness, regression)

Attachments

(2 files)

Attached file testcase

Steps to reproduce:

  1. Enable WebRender.
  2. Load the attached testcase.

Expected results:
All boxes should have the same background color: full blue.

Actual results:
Some of the boxes have a lighter background, as if they were partially translucent.

mozregression --good 2019-01-01 --bad 2019-06-01 --pref gfx.webrender.all:true -a https://bug1600141.bmoattachments.org/attachment.cgi?id=9112380

9:47.53 INFO: Last good revision: d12bb5576d0f1ce9e24ff42dd567c337431504a3
9:47.53 INFO: First bad revision: cd0c67b9aeddba87b444752885396697da387620
9:47.53 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d12bb5576d0f1ce9e24ff42dd567c337431504a3&tochange=cd0c67b9aeddba87b444752885396697da387620

cd0c67b9aeddba87b444752885396697da387620 Glenn Watson — Bug 1535976 - Add a fast path for common rounded rect clips to WR. r=kvark

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(gwatson)
Regressed by: 1535976
Assignee: nobody → gwatson

Added a patch and test case that fixes this. Try run is still pending but looks good so far.

Flags: needinfo?(gwatson)
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1128e943e324
Fix rounded clip rects with radii < 1px. r=nical
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

We ship with this bug since 68, doesn't look like a good candidate for a dot release inclusion, marking as wontfix for 71.

fix-optional for 72, but feel free to request uplift if you think it's a good idea.

Verified fixed on Nightly 73.0a1 Build ID 20191205094649 on Windows 10, macOS 10.14 and Ubuntu 18.04

Duplicate of this bug: 1579838

Given we are still early in the beta cycle, and the patch doesn't appear that complex, I think it is beta nomination worthy. Glenn?

Flags: needinfo?(gwatson)
Priority: -- → P2

It's a really simple patch, so should be an easy / low-risk uplift. We hadn't bothered with it because we didn't know of any real world content that was affected by it. But, feel free to create an uplift request given that we have other bugs fixed by it.

Flags: needinfo?(gwatson)

Comment on attachment 9112419 [details]
Bug 1600141 - Fix rounded clip rects with radii < 1px.

Beta/Release Uplift Approval Request

  • User impact if declined: May see flickering with elements with border-radius > 0 and < 1 when WebRender is in use.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed: N/A
Attachment #9112419 - Flags: approval-mozilla-beta?

Comment on attachment 9112419 [details]
Bug 1600141 - Fix rounded clip rects with radii < 1px.

webrender fix for 72.0b5

Attachment #9112419 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
Flags: in-testsuite+
Duplicate of this bug: 1606000
You need to log in before you can comment on or make changes to this bug.