Closed Bug 1600204 Opened 2 years ago Closed 2 years ago

[jsdbg2] Debugger.Frame should support .type and .constructing for suspended generator frames and remove .generator

Categories

(Core :: JavaScript Engine, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: loganfsmyth, Assigned: loganfsmyth)

References

Details

Attachments

(7 files)

These 2 are easy to support on suspended frames, so we might as well support them, and generator is just duplicating logic implemented elsewhere.

Assignee: nobody → loganfsmyth
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by loganfsmyth@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d70ec1e79887
Part 1: Support .type on suspended generator frames. r=jimb
https://hg.mozilla.org/integration/autoland/rev/73c33bf110d6
Part 2: Remove Debugger.Frame.prototype.generator since it is already on script. r=jimb
https://hg.mozilla.org/integration/autoland/rev/2828f072134e
Part 3: Support .constructing on suspended generator frames. r=jimb
https://hg.mozilla.org/integration/autoland/rev/39d1ae1352b3
Part 4: Remove documentation for unimplemented .depth property. r=jimb
https://hg.mozilla.org/integration/autoland/rev/ea1bb2f0fd39
Part 5: Support .environment on suspended generator frames. r=jimb
https://hg.mozilla.org/integration/autoland/rev/fa46d8caefde
Part 6: Support .older on suspended generator frames. r=jimb
https://hg.mozilla.org/integration/autoland/rev/31d14cf1975c
Part 7: Support .this on suspended generator frames. r=jimb
Regressions: 1644699
You need to log in before you can comment on or make changes to this bug.