Closed Bug 1600262 Opened 1 year ago Closed 1 year ago

Firefox no longer uses system preferences for accessibility.tabfocus in Catalina

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

70 Branch
Desktop
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1535742

People

(Reporter: mfishe, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

Tried to tab through links after updating to macOS Catalina, with "Use keyboard navigation to move between controls" checked in System Preferences > Keyboard > Shortcuts.

Actual results:

Tabbing didn't cycle through links. I needed to set accessibility.tabfocus to 7 in about:config to make this work.

Expected results:

Tabbing should have cycled through links without needing to go in about:config - that should be for developers only. Keyboard tabbing is for accessibility, not developers.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Component: Untriaged → DOM: UI Events & Focus Handling
OS: Unspecified → macOS
Product: Firefox → Core
Hardware: Unspecified → Desktop
Resolution: --- → DUPLICATE
Duplicate of bug: 1535742

Thanks for reporting this issue.

I tried to reproduce this with https://software.hixie.ch/utilities/js/live-dom-viewer/?saved=7400.
But I could not reproduce on macOS Catalina, i.e. tabbing could move focus to link with "Use keyboard navigation to move between controls" checked.
Note that we don't monitor the os keyboard setting changes dynamically, so you need to restart Firefox after changing the setting.

Does it still not work even after restarting the Firefox? Do you have minimum tests to reproduce this?

Flags: needinfo?(mfishe)

Hi Edgar.

I reproduced this using your link. Focus went from button1 to button2. Yes, the bug survives Firefox restarts. Indeed it has been happening since I upgraded to Catalina, and "Use keyboard navigation to move between controls" was always checked - it was checked before the upgrade, and is checked now.

Presume that link is all the minimum test you want. I upgraded a while ago (when it was released) and tabbing has not worked in any site I have visited since until setting accessibility.tabfocus to 7 very recently.

Flags: needinfo?(mfishe)

I do seem to be having wider problems with browser preferences. Or at least another one other problem. For example, my previous session does not restore on startup even though "Restore previous session" is checked in General settings. I will file a separate bug for that but maybe the 2 are linked.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
See Also: → 1535742
Status: REOPENED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1535742
You need to log in before you can comment on or make changes to this bug.