Closed Bug 1601376 Opened 1 year ago Closed 1 year ago

Windows webrender builds fail with rustc 1.39 in egl.rs

Categories

(Core :: Graphics: WebRender, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: chmanchester, Assigned: Gankra)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

error: use of deprecated item 'std::mem::uninitialized': usemem::MaybeUninitinstead
and a handful of other errors as seen in https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=e167d782709456a73a0c249d51ac53eb3f8e681b&selectedJob=279489389

Probably a dup of bug 1564873

Ah nevermind. I hadn't seen that bug 1564873 was closed. Here are the actual errors:

task 2019-12-04T03:19:17.670Z] error: use of deprecated item 'r#try': use the `?` operator instead
[task 2019-12-04T03:19:17.670Z]    --> wrench\src\egl.rs:132:13
[task 2019-12-04T03:19:17.670Z]     |
[task 2019-12-04T03:19:17.670Z] 132 |             r#try!(choose_fbconfig(display, &egl_version, api, version, pf_reqs))
[task 2019-12-04T03:19:17.670Z]     |             ^^^^^
[task 2019-12-04T03:19:17.670Z]     |
[task 2019-12-04T03:19:17.670Z]     = note: `-D deprecated` implied by `-D warnings`
[task 2019-12-04T03:19:17.670Z] 
[task 2019-12-04T03:19:17.670Z] error: use of deprecated item 'r#try': use the `?` operator instead
[task 2019-12-04T03:19:17.670Z]    --> wrench\src\egl.rs:281:17
[task 2019-12-04T03:19:17.670Z]     |
[task 2019-12-04T03:19:17.670Z] 281 |                 r#try!(create_context(self.display, &self.egl_version,
[task 2019-12-04T03:19:17.670Z]     |                 ^^^^^
[task 2019-12-04T03:19:17.670Z] 
[task 2019-12-04T03:19:17.763Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.763Z]    --> wrench\src\egl.rs:448:25
[task 2019-12-04T03:19:17.763Z]     |
[task 2019-12-04T03:19:17.763Z] 448 |     let mut config_id = mem::uninitialized();
[task 2019-12-04T03:19:17.763Z]     |                         ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.763Z] 
[task 2019-12-04T03:19:17.764Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.764Z]    --> wrench\src\egl.rs:449:27
[task 2019-12-04T03:19:17.764Z]     |
[task 2019-12-04T03:19:17.764Z] 449 |     let mut num_configs = mem::uninitialized();
[task 2019-12-04T03:19:17.764Z]     |                           ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.764Z] 
[task 2019-12-04T03:19:17.764Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.764Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.764Z]     |
[task 2019-12-04T03:19:17.764Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.764Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.764Z] ...
[task 2019-12-04T03:19:17.764Z] 473 |         hardware_accelerated: attrib!(display, config_id, ffi::egl::CONFIG_CAVEAT)
[task 2019-12-04T03:19:17.764Z]     |                               ---------------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.764Z] 
[task 2019-12-04T03:19:17.764Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.764Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.764Z]     |
[task 2019-12-04T03:19:17.764Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.764Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.764Z] ...
[task 2019-12-04T03:19:17.764Z] 475 |         color_bits: attrib!(display, config_id, ffi::egl::RED_SIZE) as u8 +
[task 2019-12-04T03:19:17.764Z]     |                     ----------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.764Z] 
[task 2019-12-04T03:19:17.764Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.764Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.764Z]     |
[task 2019-12-04T03:19:17.764Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.764Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.764Z] ...
[task 2019-12-04T03:19:17.764Z] 476 |                     attrib!(display, config_id, ffi::egl::BLUE_SIZE) as u8 +
[task 2019-12-04T03:19:17.764Z]     |                     ------------------------------------------------ in this macro invocation
[task 2019-12-04T03:19:17.764Z] 
[task 2019-12-04T03:19:17.764Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.764Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.764Z]     |
[task 2019-12-04T03:19:17.764Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.764Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.765Z] ...
[task 2019-12-04T03:19:17.765Z] 477 |                     attrib!(display, config_id, ffi::egl::GREEN_SIZE) as u8,
[task 2019-12-04T03:19:17.765Z]     |                     ------------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.765Z] 
[task 2019-12-04T03:19:17.765Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.765Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.765Z]     |
[task 2019-12-04T03:19:17.765Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.765Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.765Z] ...
[task 2019-12-04T03:19:17.765Z] 478 |         alpha_bits: attrib!(display, config_id, ffi::egl::ALPHA_SIZE) as u8,
[task 2019-12-04T03:19:17.765Z]     |                     ------------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.765Z] 
[task 2019-12-04T03:19:17.765Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.765Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.765Z]     |
[task 2019-12-04T03:19:17.765Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.765Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.765Z] ...
[task 2019-12-04T03:19:17.765Z] 479 |         depth_bits: attrib!(display, config_id, ffi::egl::DEPTH_SIZE) as u8,
[task 2019-12-04T03:19:17.765Z]     |                     ------------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.765Z] 
[task 2019-12-04T03:19:17.765Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.765Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.765Z]     |
[task 2019-12-04T03:19:17.765Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.765Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.765Z] ...
[task 2019-12-04T03:19:17.765Z] 480 |         stencil_bits: attrib!(display, config_id, ffi::egl::STENCIL_SIZE) as u8,
[task 2019-12-04T03:19:17.765Z]     |                       --------------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.765Z] 
[task 2019-12-04T03:19:17.765Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.765Z]    --> wrench\src\egl.rs:461:33
[task 2019-12-04T03:19:17.765Z]     |
[task 2019-12-04T03:19:17.765Z] 461 |                 let mut value = mem::uninitialized();
[task 2019-12-04T03:19:17.765Z]     |                                 ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.765Z] ...
[task 2019-12-04T03:19:17.765Z] 483 |         multisampling: match attrib!(display, config_id, ffi::egl::SAMPLES) {
[task 2019-12-04T03:19:17.766Z]     |                              ---------------------------------------------- in this macro invocation
[task 2019-12-04T03:19:17.766Z] 
[task 2019-12-04T03:19:17.766Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.766Z]   --> wrench\src\egl.rs:60:54
[task 2019-12-04T03:19:17.766Z]    |
[task 2019-12-04T03:19:17.766Z] 60 |             let mut major: ffi::egl::types::EGLint = mem::uninitialized();
[task 2019-12-04T03:19:17.766Z]    |                                                      ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.766Z] 
[task 2019-12-04T03:19:17.766Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.766Z]   --> wrench\src\egl.rs:61:54
[task 2019-12-04T03:19:17.766Z]    |
[task 2019-12-04T03:19:17.766Z] 61 |             let mut minor: ffi::egl::types::EGLint = mem::uninitialized();
[task 2019-12-04T03:19:17.766Z]    |                                                      ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.766Z] 
[task 2019-12-04T03:19:17.766Z] error: use of deprecated item 'std::mem::uninitialized': use `mem::MaybeUninit` instead
[task 2019-12-04T03:19:17.766Z]    --> wrench\src\egl.rs:234:34
[task 2019-12-04T03:19:17.766Z]     |
[task 2019-12-04T03:19:17.766Z] 234 |         let mut value = unsafe { mem::uninitialized() };
[task 2019-12-04T03:19:17.766Z]     |                                  ^^^^^^^^^^^^^^^^^^
[task 2019-12-04T03:19:17.766Z] 
[task 2019-12-04T03:19:18.945Z] error: aborting due to 15 previous errors
[task 2019-12-04T03:19:18.946Z] 
[task 2019-12-04T03:19:19.102Z] error: could not compile `wrench`.
[task 2019-12-04T03:19:19.102Z] 
[task 2019-12-04T03:19:19.102Z] Caused by:
Summary: Windows webrender builds fail with rustc 1.39 → Windows webrender builds fail with rustc 1.39 in egl.rs
Assignee: nobody → a.beingessner
Type: defect → task
OS: Unspecified → All
Priority: -- → P2
Hardware: Unspecified → All
Version: unspecified → Trunk
Pushed by abeingessner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec74db078a85
removed try and mem::uninitialized uses in egl.rs. r=jrmuizel
Pushed by abeingessner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c61d0841ac3f
removed try and mem::uninitialized uses in egl.rs. r=jrmuizel
Flags: needinfo?(a.beingessner)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
You need to log in before you can comment on or make changes to this bug.