Closed Bug 1601670 Opened 11 months ago Closed 11 months ago

Test Snippets do not generate telemetry events for any interactions if triggered via AS router

Categories

(Firefox :: Messaging System, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Firefox 73
Iteration:
73.1 - Dec 2 - Dec 15
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 --- verified

People

(Reporter: ppop, Assigned: nanj)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image unknown_telemetry.png

[Affected Platforms]:

  • All Windows
  • All Mac
  • All Linux

[Affected Versions]:

  • Firefox Nightly 73.0a1, Build ID 20191205094649
  • Firefox Beta 72.0b2, Build ID 20191203141951

[Prerequisites]:

  • The "browser.ping-centre.log" pref is set to "true".
  • The "browser.newtabpage.activity-stream.asrouter.devtoolsEnabled" pref is set to "true".
  • The browser console is opened.

[Steps to reproduce]:

  1. Open the browser with the profile from prerequisites and navigate to the "about:home#devtools" page.
  2. Click the "Show" button from the "SIMPLE_TEST_1" message.
  3. Observe the console output.

[Expected result]:

  • An IMPRESSION telemetry ping is displayed in the browser console.

[Actual result]:

  • The "Unknown ping type for ASRouter telemetry" error is displayed.

[Regression Range]:

[Notes]:

  • Only testing snippets are affected, the issue is not reproducible with live snippets.
  • This issue is also reproducible for the CLICK and BLOCKED events.
  • The "Unknown ping type for ASRouter telemetry" error is displayed when triggering and dismissing the snippet.
  • I have attached a screenshot of the console output:
Flags: needinfo?(andrei.br92)

The bug identified in the regression made some changes to the telemetry pipeline and the list of prefs that need to be enabled is different.
Here's the list of prefs https://docs.google.com/document/d/1oV-88Oilc-uIr9239Hqj3tFqWKQBsn6QwN6ub0DhZm8/edit#
Please reopen if you find other issues.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(andrei.br92)
Resolution: --- → INVALID
Assignee: nobody → najiang
Status: RESOLVED → REOPENED
Iteration: --- → 73.1 - Dec 2 - Dec 15
Priority: -- → P1
Resolution: INVALID → ---
Pushed by najiang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/127801c9ada5
Enable telemetry for the local Snippets message provider r=andreio
Status: REOPENED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

Does this need a Beta uplift request?

Flags: needinfo?(najiang)
Regressed by: 1594541

(In reply to Ryan VanderMeulen [:RyanVM] from comment #5)

Does this need a Beta uplift request?

No, we don't want to uplift this. Thanks!

Flags: needinfo?(najiang)

I have verified that the issue is no longer reproducible on Firefox Nightly 73.0a1 (Build ID 20191215214948) using Win 10, Mac 10.14 and Linux Debian 9.
The telemetry pings are sent for test snippets triggered from "about:home#devtools" page. I've also verified CLICK_BUTTON and BLOCK events.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.