Closed Bug 1601985 Opened 2 years ago Closed 21 days ago

Crash in [@ objc_addExceptionHandler | -[NSOpenGLLayer drawInOpenGLContext:pixelFormat:forLayerTime:displayTime:]]

Categories

(Core :: Widget: Cocoa, defect, P2)

70 Branch
x86_64
macOS
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- fix-optional

People

(Reporter: philipp, Assigned: mstange)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-8078aa87-b225-4a9b-80b8-0978a0191206.

Top 10 frames of crashing thread:

0 XUL CrashReporter::TerminateHandler toolkit/crashreporter/nsExceptionHandler.cpp:1457
1 libc++abi.dylib __cxa_rethrow 
2 libobjc.A.dylib objc_addExceptionHandler 
3 AppKit -[NSOpenGLLayer drawInOpenGLContext:pixelFormat:forLayerTime:displayTime:] 
4 QuartzCore CAOpenGLLayerDraw 
5 QuartzCore -[CAOpenGLLayer _display] 
6 AppKit -[NSOpenGLLayer display] 
7 QuartzCore CA::Layer::display_if_needed 
8 QuartzCore CA::Layer::layout_and_display_if_needed 
9 QuartzCore CA::Context::commit_transaction 

these crashes are starting to show up in the past couple of days starting with firefox 70 and upwards and exclusively from users on macos 10.11.

user comments in the crash reports generally indicate that the crash is taking place while they are opening the file-picker to initiate an upload to a website.

Flags: needinfo?(mstange)
Priority: -- → P2

This seems to be another variant of "file picker can only display its CALayers on the main thread", which also seems to be the problem in bug 1579431.

Assignee: nobody → mstange
Status: NEW → ASSIGNED
Flags: needinfo?(mstange)
Duplicate of this bug: 1595998

Too late for a fix in 72, but we still could take a patch for 73/74.

Severity: normal → S3

Closing because no crashes reported for 12 weeks.

Status: ASSIGNED → RESOLVED
Closed: 21 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.