Closed Bug 1603020 Opened 1 year ago Closed 1 year ago

Opening Findbar broke contenteditable caret moving

Categories

(Core :: Find Backend, defect, P1)

71 Branch
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
mozilla74
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- wontfix
firefox72 + wontfix
firefox73 + verified
firefox74 + verified

People

(Reporter: jacekbogd, Assigned: enndeakin)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

Steps to reproduce:

The issue seems to be reproducible from 71.0 Firefox version (tested on Windows 10).

  1. Open any page sample with contenteditable element. You can use https://codepen.io/jacekbogdanski/pen/QWwNOoV
  2. Open FF search bar using CTRL + F keyboard combination.
  3. Focus contenteditable element.
  4. Start navigating using keyboard arrow keys.

Keyboard navigation works fine until you open a search bar. The issue didn't occur on Firefox 70.

Actual results:

It is possible to use all keys even if the search bar of Firefox is opened.

Expected results:

It is not able to move a caret.

Summary: Opening search bar brokes contenteditable navigation → Opening search bar brokes contenteditable keystrokes

I can reproduce the issue on Nightly63.0a1 Windows10 as well as Firefox71.

STR:

  1. Open any page sample with contenteditable element. You can use https://codepen.io/jacekbogdanski/pen/QWwNOoV
  2. Focus contenteditable element by mouse click.
  3. Open Findbar using CTRL + F keyboard combination.
    --- The caret can be moved to left and right with the left/right arrow keys. OK
  4. Focus contenteditable element again.
  5. Start navigating using keyboard arrow keys.
    --- It is not able to move a caret. BUG

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5b303cb0a0a39e2bd4a6fea53535fe8e1d829b97&tochange=e33c3e14ee40f88d1775952e309dc2a617eb97f7

Status: UNCONFIRMED → NEW
Component: Untriaged → Find Backend
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Regressed by: 1553384
Summary: Opening search bar brokes contenteditable keystrokes → Opening Findbar brokes contenteditable caret moving

[Tracking Requested - why for this release]:Mail compose window Yahoo! Japan is also affected if Findbar is opened

Also affected to https://mail.yahoo.co.jp/ compose window

Has Regression Range: --- → yes
Has STR: --- → yes

Too late for 71.

Summary: Opening Findbar brokes contenteditable caret moving → Opening Findbar broke contenteditable caret moving

Hi Mike, can you please take a look at this while Neil is on PTO?

Flags: needinfo?(mdeboer)

I can't reproduce this bug at all.

I can still reproduce the issue with STR Comment#1 on Nightly73.0a1(20191222215627) Windows10.

OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop

Tentatively assigning to Neil because he said planned to investigate these findbar regressions next week, unless Mike makes progress before then.

Tracking for Fission dogfooding (M5)

Fission Milestone: --- → M5
Assignee: nobody → enndeakin
Priority: -- → P1

I can reproduce this bug in both Fission and non-Fission mode. Caret navigation is broken even after closing the Findbar.

We don't need to track this bug for Fission since non-Fission mode is also broken.

Fission Milestone: M5 → ---
Status: NEW → ASSIGNED
See Also: → 1606707
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a8af38a964f
allow sendMessageToActor to send the message to all descendants, not just process roots, r=mconley
https://hg.mozilla.org/integration/autoland/rev/3f585af46d39
send state update messages to all child actors, r=mikedeboer
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

I can reproduce the issue on Nightly74.0a1(20200120094216) Windows10.
And I verified that the issue was fixed in Nightly74.0a1(20200121093246).

Status: RESOLVED → VERIFIED

Please nominate this for Beta approval when you get a chance.

Flags: needinfo?(mdeboer) → needinfo?(enndeakin)

Comment on attachment 9119183 [details]
Bug 1603020, send state update messages to all child actors, r=mikedeboer

Beta/Release Uplift Approval Request

  • User impact if declined: After opening the findbar, typing/moving the caret does not work in some contenteditable fields
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed: None
Flags: needinfo?(enndeakin)
Attachment #9119183 - Flags: approval-mozilla-beta?
Attachment #9119182 - Flags: approval-mozilla-beta?

Comment on attachment 9119183 [details]
Bug 1603020, send state update messages to all child actors, r=mikedeboer

regression fix, approved for 73.0b11

Attachment #9119183 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9119182 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced the initial issue using Release version 72.0.2.
Verified - Fixed in latest Beta 73.0b11 (Build id: 20200128001646) using Windows 10.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.