Closed Bug 1603226 Opened 1 year ago Closed 1 year ago

Enable signon.userInputRequiredToCapture.enabled and prompt when field values differ from their defaultValue

Categories

(Toolkit :: Password Manager, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
mozilla73
Tracking Status
firefox73 --- verified

People

(Reporter: sfoster, Assigned: sfoster)

References

Details

Attachments

(1 file)

Bug 1388674 introduced the signon.userInputRequiredToCapture.enabled pref, but left it defaulted off. If we check for user input or fields where their .value !== .defaultValue, this should minimize the regression risk and allow us to turn that pref on by default.

Priority: -- → P1
Assignee: nobody → sfoster
Status: NEW → ASSIGNED
Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8ef1a9045a64
enable signon.userInputRequiredToCapture.enabled by default, and allow capture when any field value !== its defaultValue. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

Hey Sam,
The pref is indeed enabled by default on the latest Nightly 73.0a1 (2020-01-05) (64-bit), however it doesn't work with Testcase 1: Username and password fields filled by JS from Bug 1388674. The save prompt will be displayed even if the fields were not edited. I attached a log to the mentioned bug, hope it helps.
Won't NI? you here since I already did in the other Bug 1388674 with the same info.

Clarification were offered in Bug 1388674 regarding the expected behavior.
The pref "signon.userInputRequiredToCapture.enabled" is enabled by default on Windows 10, MacOS 10.14 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Depends on: 1620482
Regressions: 1627658
You need to log in before you can comment on or make changes to this bug.