Closed Bug 1603863 Opened 8 months ago Closed 7 months ago

Takes eight tabs instead of two now to get from To field to message body

Categories

(Thunderbird :: Message Compose Window, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1601748

People

(Reporter: jik, Unassigned)

References

(Regression)

Details

(Keywords: regression)

After bug 440377, it now takes way too many tabs to get from the To field to the message body.

Before, it took two tabs: one to get to the Subject line and a second to get to the body.

Now it takes eight tabs, since you have to get over all the other addressee fields.

Please reconsider how tabbing works here!

Flags: needinfo?(alessandro)

P.S. I know I'm posting a lot of bugs about this new functionality, so I just want to clarify that overall I think it is a major improvement and I'm just trying to be helpful by pointing out some rough edges. Thank you to Alessandro for building it!

Thank you again for this feedback, and don't worry at all, I know you're writing these bugs to help us improve the section, and I'm extremely grateful for your thoroughness.

This issue will most likely be resolved by bug 1601748, which will implement a better UI for the entire header area, or bug 1602372, which is currently under discussion trying to figure out the best approach to handle keyboard navigation.

Let's leave it open for now, with adding a see also to the two bug I mentioned before.

Thank you so much!

Flags: needinfo?(alessandro)

(In reply to Jonathan Kamens from comment #0)

After bug 440377, it now takes way too many tabs to get from the To field to the message body.
Now it takes eight tabs, since you have to get over all the other addressee fields.

It was a minimum of 7 tabs from the cursor in recipient input field (only if you also have newsgroups, otherwise less), but the number of tabs to reach body was unlimited because every pill added another tab stop. There's agreement now on my bug 1602372 to exclude pills from the tab focus ring, as they are well and correctly navigable with cursor keys.

This was fixed by bug 1601748.
I've also started the work on bug 1602372, so this is a WONTFIX for me.

Flags: needinfo?(jik)

Not clear why this is needinfo to me?

I NI you because you were the one reporting this bug.
I wanted to hear your feedback on the matter after the latest updates on daily.

It's much better now, thanks.

Flags: needinfo?(jik)
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → WONTFIX

(In reply to Alessandro Castellani (:aleca) (PTO to 17th Jan 2020, sporadically reading bugmail) from comment #4)

This was fixed by bug 1601748.
I've also started the work on bug 1602372, so this is a WONTFIX for me.

Please don't hide the good work which you are doing. As you said, you've actually fixed the basic case of this in bug 1601748 (e.g. by moving CC/BCC/other-buttons before the To field), and we're going to fix infinite tab stops in bug 1602372, so it will be completely fixed soon. Wontfix looks bad on the record, and it can't be WONTFIX when it's actually explicitly FIXED.
In this case, we can just make it a duplicate of bug 1601748 as we're still in iterations. Alternatively (albeit rarely), if a certain bug explicitly gets fixed as a subset of some other bug, it could also be resolved "Fixed by bug 1601748".

Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1601748
You need to log in before you can comment on or make changes to this bug.