Closed Bug 1603946 Opened 2 years ago Closed 2 years ago

Perma xpcshell.ini:browser/components/extensions/test/xpcshell/test_ext_pageAction_shutdown.js | xpcshell return code: 0 when Gecko 73 merges to Beta on 2020-01-06

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set
major

Tracking

(Root Cause:Coding: Other, firefox-esr68 unaffected, firefox71 unaffected, firefox72 unaffected, firefox73blocking verified)

VERIFIED FIXED
mozilla73
Root Cause Coding: Other
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 blocking verified

People

(Reporter: dluca, Assigned: mixedpuppy)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta simulation:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=2010ae5368fd6474a4d8e1c65f33622adfcd61c6&selectedJob=281186835

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=281186835&repo=try&lineNumber=4380

 INFO -  TEST-START | xpcshell.ini:browser/components/extensions/test/xpcshell/test_ext_pageAction_shutdown.js
[task 2019-12-14T13:16:10.042Z] 13:16:10  WARNING -  TEST-UNEXPECTED-FAIL | xpcshell.ini:browser/components/extensions/test/xpcshell/test_ext_pageAction_shutdown.js | xpcshell return code: 0
[task 2019-12-14T13:16:10.042Z] 13:16:10     INFO -  TEST-INFO took 360ms
[task 2019-12-14T13:16:10.042Z] 13:16:10     INFO -  >>>>>>>
[task 2019-12-14T13:16:10.043Z] 13:16:10     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2019-12-14T13:16:10.043Z] 13:16:10     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2019-12-14T13:16:10.043Z] 13:16:10     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2019-12-14T13:16:10.043Z] 13:16:10     INFO -  running event loop
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  xpcshell.ini:browser/components/extensions/test/xpcshell/test_ext_pageAction_shutdown.js | Starting testAppShutdown
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  (xpcshell/head.js) | test testAppShutdown pending (2)
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  PID 4877 | 1576329369909	addons.manager	DEBUG	Application has been upgraded
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  PID 4877 | JavaScript strict warning: resource://gre/modules/AddonManager.jsm, line 676: ReferenceError: reference to undefined property "version"
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  PID 4877 | 1576329369909	addons.manager	ERROR	startup failed: TypeError: Services.appinfo.version is undefined(resource://gre/modules/AddonManager.jsm:692:1) JS Stack trace: startup@AddonManager.jsm:692:1
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  PID 4877 | startup@AddonManager.jsm:3474:26
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  PID 4877 | observe@addonManager.js:87:29
[task 2019-12-14T13:16:10.045Z] 13:16:10     INFO -  PID 4877 | promiseStartupManager@AddonTestUtils.jsm:987:34
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | testAppShutdown@test_ext_pageAction_shutdown.js:46:9
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | run_next_test/_run_next_test/<@head.js:1567:22
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | _run_next_test@head.js:1567:38
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | run@head.js:735:9
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | _do_main@head.js:246:6
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | _execute_test@head.js:573:5
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | @-e:1:1
[task 2019-12-14T13:16:10.046Z] 13:16:10     INFO -  PID 4877 | 1576329369910	addons.manager	DEBUG	Completed startup sequence
[task 2019-12-14T13:16:10.047Z] 13:16:10     INFO -  PID 4877 | JavaScript error: resource://gre/modules/AddonManager.jsm, line 1516: NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
[task 2019-12-14T13:16:10.047Z] 13:16:10     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2019-12-14T13:16:10.047Z] 13:16:10     INFO -  Unexpected exception NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized
[task 2019-12-14T13:16:10.047Z] 13:16:10     INFO -  callManagerListeners@resource://gre/modules/AddonManager.jsm:1516:24
[task 2019-12-14T13:16:10.049Z] 13:16:10     INFO -  startup@resource://gre/modules/AddonManager.jsm:845:10
[task 2019-12-14T13:16:10.049Z] 13:16:10     INFO -  startup@resource://gre/modules/AddonManager.jsm:3474:26
[task 2019-12-14T13:16:10.049Z] 13:16:10     INFO -  observe@resource://gre/modules/addonManager.js:87:29
[task 2019-12-14T13:16:10.049Z] 13:16:10     INFO -  promiseStartupManager@resource://testing-common/AddonTestUtils.jsm:987:34
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  testAppShutdown@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/tests/browser/components/extensions/test/xpcshell/test_ext_pageAction_shutdown.js:46:9
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  run_next_test/_run_next_test/<@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:1567:22
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  _run_next_test@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:1567:38
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  run@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:735:9
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  _do_main@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:246:6
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  _execute_test@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:573:5
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  @-e:1:1
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  exiting test
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  "CONSOLE_MESSAGE: (info) 1576329369909	addons.manager	DEBUG	Application has been upgraded"
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "ReferenceError: reference to undefined property "version"" {file: "resource://gre/modules/AddonManager.jsm" line: 676}]"
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "1576329369909	addons.manager	ERROR	startup failed: TypeError: Services.appinfo.version is undefined(resource://gre/modules/AddonManager.jsm:692:1) JS Stack trace: startup@AddonManager.jsm:692:1
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  startup@AddonManager.jsm:3474:26
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  observe@addonManager.js:87:29
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  promiseStartupManager@AddonTestUtils.jsm:987:34
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  testAppShutdown@test_ext_pageAction_shutdown.js:46:9
[task 2019-12-14T13:16:10.050Z] 13:16:10     INFO -  run_next_test/_run_next_test/<@head.js:1567:22
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  _run_next_test@head.js:1567:38
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  run@head.js:735:9
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  _do_main@head.js:246:6
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  _execute_test@head.js:573:5
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  @-e:1:1" {file: "resource://gre/modules/Log.jsm" line: 723}]
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  append@resource://gre/modules/Log.jsm:723:12
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  log@resource://gre/modules/Log.jsm:379:16
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  error@resource://gre/modules/Log.jsm:387:10
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  startup@resource://gre/modules/AddonManager.jsm:840:14
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  startup@resource://gre/modules/AddonManager.jsm:3474:26
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  observe@resource://gre/modules/addonManager.js:87:29
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  promiseStartupManager@resource://testing-common/AddonTestUtils.jsm:987:34
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  testAppShutdown@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/tests/browser/components/extensions/test/xpcshell/test_ext_pageAction_shutdown.js:46:9
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  run_next_test/_run_next_test/<@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:1567:22
[task 2019-12-14T13:16:10.051Z] 13:16:10     INFO -  _run_next_test@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:1567:38
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  run@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:735:9
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  _do_main@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:246:6
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  _execute_test@/Users/cltbld/tasks/task_1576322119/build/tests/xpcshell/head.js:573:5
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  @-e:1:1
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  "
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  "CONSOLE_MESSAGE: (info) 1576329369910	addons.manager	DEBUG	Completed startup sequence"
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  "CONSOLE_MESSAGE: (error) [JavaScript Error: "NS_ERROR_NOT_INITIALIZED: AddonManager is not initialized" {file: "resource://gre/modules/AddonManager.jsm" line: 1516}]"
[task 2019-12-14T13:16:10.052Z] 13:16:10     INFO -  <<<<<<<
[task 2019-12-14T13:16:10.077Z] 13:16:10     INFO -  TEST-START | browser/components/urlbar/tests/unit/test_UrlbarQueryContext_restrictSource.js
Component: Untriaged → Address Bar
Flags: needinfo?(htwyford)
Product: WebExtensions → Firefox
Regressed by: 1590450
Component: Address Bar → Untriaged
Flags: needinfo?(htwyford)
Product: Firefox → WebExtensions
No longer regressed by: 1590450

Kris, is this a regression of bug 1596918?

Flags: needinfo?(kmaglione+bmo)
Regressed by: 1596918

Anyone around who might try and fix this before the merge on Jan. 6?

Flags: needinfo?(jmathies)

Here's the more likely regression bug based on what I tested to fix this.

Assignee: nobody → mixedpuppy
Flags: needinfo?(kmaglione+bmo)
Flags: needinfo?(jmathies)
Regressed by: 1602168
No longer regressed by: 1596918
Pushed by scaraveo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5b0890227584
fix perma fail on 73 merge due to loading pageinfo before creating appinfo r=twisniewski
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73

Please specify a root cause for this bug. See :tmaity for more information.

Root Cause: --- → ?

RCA Coding Other:

I'm not really sure how to categorize this one. The regressing bug caused a change in order of loading the services module (if loading the module that was modified), whereas many xpcshell tests need to configure appinfo before the services module is loaded. I don't really consider the change being in error, nor the test. The loading order here can often be intermittent and easily missed when doing these changes.

Root Cause: ? → Coding: Other
You need to log in before you can comment on or make changes to this bug.