Closed Bug 1604198 Opened 1 year ago Closed 1 year ago

Top Sites on multiple rows are displayed on one row under 1122px browser width

Categories

(Firefox :: New Tab Page, defect, P1)

All
Unspecified
defect

Tracking

()

VERIFIED FIXED
Firefox 73
Iteration:
73.2 - Dec 16 - Jan 5
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- unaffected
firefox72 --- unaffected
firefox73 --- verified

People

(Reporter: vvalentina, Assigned: thecount)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected Versions]:

  • Firefox Nightly 73.0a1 (Build ID 20191215214948)

[Affected Platforms]:

  • Win 10
  • Mac 10.14
  • Linux Debian 9

[Steps to reproduce]:

  1. Open about:preferences#home page.
  2. In Firefox Home Content section set Top Sites to be listed on 2 rows.
  3. Open a new tab page.
  4. Resize the browser to 1121 width.
  5. Observe Top Sites section.

[Expected results]:
Top Sites section is displayed on 2 rows.

[Actual results]:
Top Sites section is displayed on 1 row.

[Additional notes]:

  • Under 1121px browser width Top Sites are displayed in 1 row, no matter how is set in about:preferences#home page.
  • Over 1121px browser width Top Sites are displayed as set in about:preferences#home page.
  • Issue is not reproducible with Discovery Stream disabled.
  • Issue is not reproducible for Highlights section.
Assignee: nobody → gsuntop
Iteration: --- → 73.2 - Dec 16 - Jan 5
Priority: -- → P1
Iteration: 73.2 - Dec 16 - Jan 5 → ---
Priority: P1 → P2
Duplicate of this bug: 1605056
Duplicate of this bug: 1605112

Raising the severity to critical based on the multiple reports we've got up to this point and the fact that we're planning on turning on DS for the rest of the world.

Severity: normal → critical
Priority: P2 → P1

I strongly suspect this is caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1594537

Iteration: --- → 73.2 - Dec 16 - Jan 5
Regressed by: 1594537

(In reply to Scott [:thecount] Downe from comment #4)

I strongly suspect this is caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1594537

That is what I came uo with when I checked with mozregression,

https://bugzilla.mozilla.org/show_bug.cgi?id=1605056

I think I got a fix.

To test:

  1. Ensure Discovery Stream is on.
  2. Set to 1 row of topsites.
  3. Check all breakpoints.
  4. Ensure you always have 1 row of topsites in first and second breakpoint, and ensure all rows are always of equal length.
  5. The smaller breakpoints might have more rows, but should at least be of equal length of other rows.

Do steps 2-5 again with 2 rows of topsites, and again with 3 rows of topsites, then with 4.

Gavin, I got a fix pushed up and assigned to you for review.

I think the old Topsites css has coverage for our case, so I think if we delete the right css overrides, the old css we need covers this.

Let me know if you can find issues with this strategy.

Assignee: gsuntop → sdowne
Pushed by gsuntop@getpocket.com:
https://hg.mozilla.org/integration/autoland/rev/b69c49bc5500
Multiple topsite rows with Discovery Stream and responsive design. r=gvn
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

I have verified that this issue is no longer reproducible with the steps provided in the Steps to Reproduce section and the ones from Comment 7 on Firefox Nightly 73.0a1 (Build ID: 20191229212642) on Windows 10 x64, Mac 10.14.6 and Ubuntu 18.04.2.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.