Closed Bug 1604948 Opened 8 months ago Closed 7 months ago

Graphical corruption Intel HD Graphics 630

Categories

(Core :: Widget: Gtk, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: yoasif, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(7 files)

Happy to run debug builds or enable logging to dig into this further.

Once every few starts of Firefox on my machine ends up corrupting the display of my Wayland session badly - what looks like a lot of stray marks on my display are seen overlaid on top of all windows, not just Firefox.

This may be a driver bug, but I am not sure how to dig into that, and I only see this issue when starting Firefox -- but not on every start.

Logging out and logging back in resolves the issue, but there is a chance that it recurs on next launch.

I just experienced this happening 3 times in a row, so finally reporting a bug. Really just want to figure out what is going on.

Attached file about:support
Flags: needinfo?(aosmond)
Blocks: wr-linux
Priority: -- → P3

This seems maybe different from the other UI glitches we have seen recently?

Yeah, I think this is different. Asif, do you have an idea of how long this has been happening for?

Flags: needinfo?(yoasif)

At least a few weeks -- I don't know how to reproduce it consistently, so I never bothered to file a bug. It happened enough times in a row today for me to decide to file a bug to get to the bottom of it.

I will also note that since it corrupts my display and persists until logout, I also never bothered to run a mozregression, because it'd be hard to determine whether the issue is recurring or whether I am seeing the corruption from previous builds.

Flags: needinfo?(yoasif)

Since the problem persists until logout it suggests there's probably some kind of driver bug that Firefox is hitting. It may be worth filing a bug here https://gitlab.freedesktop.org/mesa/mesa/issues and perhaps with the help of the mesa developers we can figure out what's happening.

Team, I realized that I could use mozregression inside tmux to persist my mozregression session while logging in and out.

Hope this helps -- it's a pretty big pushlog and I don't want to hazard a guess as to what the issue might be:

43:52.31 INFO: Narrowed inbound regression window from [25bf8e09, db1ddab2] (3 builds) to [425af188, db1ddab2] (2 builds) (~1 steps left)
43:52.31 INFO: No more inbound revisions, bisection finished.
43:52.31 INFO: Last good revision: 425af188aae948e80e6095f096c7835809b2197f
43:52.31 INFO: First bad revision: db1ddab2985dfee5be9524e305cd314b6dcac501
43:52.31 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=425af188aae948e80e6095f096c7835809b2197f&tochange=db1ddab2985dfee5be9524e305cd314b6dcac501

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

Based on the comments on https://gitlab.freedesktop.org/mesa/mesa/issues/2249:

To me that looks like an actor stuck in the scene graph of the compositor. You see it even in the overview mode. It's not visible on the Alt-tab widget (which must be above in the scene graph tree).

this seems like a regression from bug 1592350.

The issue doesn't occur for me when I am using a Xorg session.

I took a log using WAYLAND_DEBUG=1 and am attaching it here -- I'll attach a video that corresponds to this log in the next comment.

I opened Firefox, waited to see the issue, then quit Firefox using Ctrl-q.

Flags: needinfo?(stransky)
Blocks: wayland
Has Regression Range: --- → yes
Regressed by: 1592350

This is likely a bug in GS 3.34, fixed by https://gitlab.gnome.org/GNOME/mutter/merge_requests/924 and https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/815, included in 3.34.2 which should arrive soon in Ubuntu 19.10.

FWIW, I am running Ubuntu 20.04 and I surprisingly don't have the latest GNOME Shell, so I am waiting for it. Hoping that resolves it.

Thanks for the info Robert.

Flags: needinfo?(stransky)

According to https://packages.ubuntu.com/search?suite=focal&keywords=mutter Ubuntu 20.04 now has GS 3.34.2, so if my guess was correct the issue should be gone now. Asif, can you confirm?

Flags: needinfo?(yoasif)

Robert, I have had that version of mutter for a while, but am still seeing the issue. gnome-shell isn't at 3.34.2 though.

Flags: needinfo?(yoasif)

Asif I expect you can't reproduce it when WebRender is disabled, correct? Can you try GL compositor instead of it?

Flags: needinfo?(yoasif)

btw. I have the same gfx hw but I don't see it although I'm running Fedora 31 / gnome-shell-3.34.2-1.

(In reply to Asif Youssuff from comment #16)

Robert, I have had that version of mutter for a while, but am still seeing the issue. gnome-shell isn't at 3.34.2 though.

Ah my bad, I somehow assumed they release them in tandem. Then we still have to wait.

Concerning Fedora 31: it has the Mutter/GS patches for a while already, similar to how you backport Firefox Wayland patches. So the Ubuntu Wayland experience is always 1-2 month behind :/

(In reply to Martin Stránský [:stransky] from comment #17)

Asif I expect you can't reproduce it when WebRender is disabled, correct? Can you try GL compositor instead of it?

It works fine when WebRender is disabled.

However, with GL acceleration (layers.acceleration.force-enabled:true), I experienced some of the same issues I see when WR is enabled -- an entry in the alt-tab switcher of "unknown" and stuck windows (cannot see other windows over a dead Firefox window, even when switching virtual desktops). When using alt-`, I can see other windows updating, but I cannot see them if I switch to them.

I tried this twice - I didn't reproduce it the second time (after logging out and logging in again), so it is similar to the WR scenario in that it doesn't happen every time Firefox is started.

I also didn't see the same stray marks on the screen left on top of windows - I have seen the above issues, but wanted to report the stray marks first, since that issue appeared first and I surmised that the other issues might be related.

Flags: needinfo?(yoasif)

(In reply to Asif Youssuff from comment #20)

...(cannot see other windows over a dead Firefox window, even when switching virtual desktops). When using alt-`, I can see other windows updating, but I cannot see them if I switch to them. ...

I think this part makes it quite obvious that it is not a Firefox issue but a compositor one: an app like Firefox should never be able to stop you from seeing other windows (at least on Wayland, X11 might be another story). And it sounds exactly like the bug fixed in Mutter/GS 3.34.2.

New wrinkle -- I just now saw the issue with Basic compositing (no WR or OpenGL acceleration). Screenshot and about:support to follow. Saw this after Firefox crashed and I restarted it (crash was likely Fission related, not this issue).

Seems like a widget gtk issue now.

Component: Graphics: WebRender → Widget: Gtk

Went ahead and filed a report with Ubuntu as well: https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1858120

The component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --

It looks like the latest gnome-shell fixed the issue for me:

apt policy gnome-shell
gnome-shell:
Installed: 3.34.3-1ubuntu1
Candidate: 3.34.3-1ubuntu1
Version table:
*** 3.34.3-1ubuntu1 500
500 http://us.archive.ubuntu.com/ubuntu focal/main amd64 Packages
100 /var/lib/dpkg/status

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(aosmond)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.