Closed Bug 1606036 Opened 11 months ago Closed 11 months ago

Implement high contrast mode in GTK.

Categories

(Core :: Widget: Gtk, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla73
Tracking Status
firefox73 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(1 file)

No description provided.

Over in bug 1604761 I realized that GTK has a high-contrast accessibility
setting, that GTK does not honor the same way as windows does.

There's no good reason for that IMO, and high contrast mode on windows is
getting some love.

This hooks the relevant parts of the GTK widget code so that we also avoid
websites overriding high contrast colors (via PreferenceStyleSheet and co).

Maybe it should be part of the release notes?

Type: defect → enhancement
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dbeea4db8ede
Implement high contrast mode in GTK. r=stransky
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla73
Duplicate of this bug: 239914
Duplicate of this bug: 1064164

Hello Emilio,

Many thanks for working on this.

I'm myself visual-impaired and a user of the high contrast theme of GTK, what should have change? I'm seen no improvement despite I'm using nightly.

Note that on Windows the default high contrast theme for Firefox is not so good because it uses black background whereas it should use white background as lot of user uses the inverse color function because most of the webpage are on white background.

Best regards.

Flags: needinfo?(emilio)

Hmm, it should just work, as long as "about:preferences" > "Colors" has the "Override the colors specified by the page with your selections above" set to "Only with high contrast themes".

If it is not working out of the box I'd be interested in why, what's the name of your GTK theme?

Flags: needinfo?(emilio)

If it is not working out of the box I'd be interested in why, what's the name of your GTK theme?

It works out of the box indeed but IMHO this is not a user improvement but a regression because now users of the high contrast theme see all the issues with this Firefox mode. The main issues regarding this are: images are hidden often like the Facebook logo and it is difficult to differentiate part of a website because border are not respected.
A good example of this is the Firefox preferences where the highlight are not respected at all.

Could we revert this change or change the default Firefox behavior for this? As a visual-impaired person using the high contrast theme I don't want see site differently as others except if I request it.

The default behavior IMHO should be never. Usually low-user who want to improve contrast on website user color filters of the OS or screen magnifier or third-party module like the Dark Mode module that works pretty well.

Best regards.

There is UI to disable this: about:preferences > Colors > Override the colors specified by the page with your selections above > Never.

It'd be ok to make "Only with high contrast themes" not default, but that's more of a question for the a11y team.

Regressions: 1621047
Regressions: 1623938
You need to log in before you can comment on or make changes to this bug.