[RFE]Option to stop animated images (on site-by-site basis)

NEW
Unassigned

Status

()

Core
Image Blocking
P3
enhancement
16 years ago
9 years ago

People

(Reporter: Jason Price, Unassigned)

Tracking

Trunk
Future
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla has the wonderful "Block images from this server" option.  I'd like
another one right next to it.

I wish I could right click on an animated image, and select "Stop animated image".

I don't want to turn them all off (which there is an option for).  I just want
to stop the hyper annoying ones.

Thanks;
Jason
(Reporter)

Comment 1

16 years ago
Note: This might be (well, probably is) attached to the wrong component... I
couldn't find a better one.  :-(

Comment 2

16 years ago
Isn't 'Preferences/Privacy/Images/Loop images' enough for you?
(Okay, I remember earlier netscape version to stop animated gifs
 when pressing the stop button, but ...)
(Reporter)

Comment 3

16 years ago
No, the preferences, while very nice, are a global change.  I just want to stop
the  images that are REALLY annoying, on a case by case basis.

I can block those ad servers, but I don't like doing that, since advertising is
how some sites stay in business.

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 70030 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 6

16 years ago
*** Bug 162839 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Guys, this one is NOT a dupe og bug 70030. That bug deals with ALL animated
images at once, and this one requires a context menu item for a _single_ image.
Rather dependency than dupe.

==> REOPEN
Status: VERIFIED → UNCONFIRMED
Depends on: 70030
Resolution: DUPLICATE → ---

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

16 years ago
I would like to see this option too, but extended to be a toggle between started
and stopped behaviour. When showing the context menu over an animated image...

1) If it is animated (displaying the animation), include the option "Stop Image
Animation" in the context menu, which when selected stops the animation.

2) If it is not animated, include the option "Show Image Animation" in the
context menu, which when selected starts the animation.

Comment 9

16 years ago
The image context menu is already pretty long (that's not even considering
linked images). I'm not sure the UI people, who are more often than not trying
to shorten any menus down, are going to go for something like this. I'd say bug
70030 stands a much better chance at getting fixed and, if it does, it would
likely reduce any chances of this bug being considered.

Comment 10

16 years ago
>The image context menu is already pretty long

Perhaps this is true, but it need not exclude functionality which is useful, as there are other ways around just adding an item to a long list. Eg move less commonly used functionality to a submenu. Or perhaps even by doing it like Opera, and using a 'quick preference' menu.

The reason I feel this is useful and timesaving, is that for people who browse with 'show animations' set to 'only once' or 'not at all', there is no way to force a particular image on the page to animate without a long and painful process of...
* going into preferences
* finding the image setting and changing it to 'show all animations'
* reloading the page
* looking at the pretty animation
* then the preferences again to turn it off.

It's pretty painful, especially compared to something like Opera which allows you to turn it on and off very easily.

Brodie.

Updated

16 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Summary: Option to stop animated images → Option to stop animated images (onsite-by-site basis)
Target Milestone: --- → mozilla1.3alpha

Updated

16 years ago
Blocks: 119597

Comment 11

16 years ago
*** Bug 85621 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: Option to stop animated images (onsite-by-site basis) → Option to stop animated images (on site-by-site basis)
Mass reassigning of Image manager bugs to mstoltz@netscape.com, and futuring.
Most of these bugs are enhancement requests or are otherwise low priority at
this time.
Assignee: morse → mstoltz
Status: ASSIGNED → NEW
Target Milestone: mozilla1.3alpha → Future

Comment 13

15 years ago
Or just add a simple command to stop animated GIFs. For example as in IE, the
"stop" button stops animations.

Comment 14

15 years ago
No, my idea (Bug #85621) was to be able to stop animations from eg. banner
servers (permanently) but keep animation in images from the site itself. So
making the stop button do it is not enough.

Updated

15 years ago
QA Contact: tever → nobody
Recommend wontfix, but I leave it to a future module owner to decide. We can't
have per-site prefs for everything. Have to keep the feature bloat under
control. This would be a good Mozdev project if someone wanted to write one.
Status: NEW → ASSIGNED
Summary: Option to stop animated images (on site-by-site basis) → [RFE]Option to stop animated images (on site-by-site basis)
Assignee: security-bugs → nobody
Status: ASSIGNED → NEW
QA Contact: nobody → image-blocking
You need to log in before you can comment on or make changes to this bug.