Closed Bug 1606794 Opened 11 months ago Closed 11 months ago

"Take Element Screenshot" no longer uses the element's browsing context

Categories

(Testing :: Marionette, defect, P1)

Version 3
defect

Tracking

(firefox-esr68 unaffected, firefox71 wontfix, firefox72 wontfix, firefox73 fixed, firefox74 fixed)

RESOLVED FIXED
mozilla74
Tracking Status
firefox-esr68 --- unaffected
firefox71 --- wontfix
firefox72 --- wontfix
firefox73 --- fixed
firefox74 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files, 3 obsolete files)

Reported as: https://github.com/mozilla/geckodriver/issues/1666

This is most likely a regression from bug 1559592 when we moved to the Fission compatible drawSnapshot command. Maybe it just gets the wrong browsing context id, and as such captures the wrong area.

Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Priority: P3 → P1
Summary: WebDriver:TakeScreenshot and WebDriver:TakeElementScreenshot no longer capture frames content → WebDriver:TakeScreenshot no longer captures frames content

Missed to fix an import for the element_dimensions() helper. Here a new try build for wd2 jobs only:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d4cdc9bfe0fbc724b0532bd1bf40c1195eab15e3

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d73cb1b0011d
[marionette] Fixed WebDriver:TakeScreenshot to capture frame's content. r=marionette-reviewers,ato
https://hg.mozilla.org/integration/autoland/rev/565340ce11e8
[wdspec] Add Element.screenshot() command to webdriver client. r=webdriver-reviewers,jgraham
https://hg.mozilla.org/integration/autoland/rev/b2b3f10527c3
[wdspec] Improve screenshot tests for checking the contents of frames. r=webdriver-reviewers,ato
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/21049 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Upstream PR merged by moz-wptsync-bot
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Firefox 72 will be released tomorrow. As such there is no way to get it fixed for that release, and it will ride the trains. We surely will land it for the next 73 beta!

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla74 → ---

The backout was required because the landed change isn't WebDriver compliant! Compared to Take Element Screenshot, which needs the specific browsing context the element lives in, Take Screenshot always has to use the top-level browsing context. See also bug 1398087.

Status: REOPENED → ASSIGNED
Summary: WebDriver:TakeScreenshot no longer captures frames content → "Take Element Screenshot" no longer uses the element's browsing context
Depends on: 1398087

I will continue on this bug once a new webdriver test has been written for bug 1398087.

Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/21065 for changes under testing/web-platform/tests
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/21066 for changes under testing/web-platform/tests
Upstream PR was closed without merging
Flags: needinfo?(nbeleuzu)
Summary: "Take Element Screenshot" no longer uses the element's browsing context → WebDriver:TakeScreenshot no longer captures frames content
Summary: WebDriver:TakeScreenshot no longer captures frames content → "Take Element Screenshot" no longer uses the element's browsing context
Upstream PR merged by jgraham
Flags: needinfo?(nbeleuzu)
Blocks: webdriver
Attachment #9119441 - Attachment is obsolete: true
Attachment #9119442 - Attachment is obsolete: true
Attachment #9119443 - Attachment is obsolete: true
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b5606ee2560
[marionette] Fixed WebDriver:TakeScreenshot to capture frame's content. r=marionette-reviewers,ato
https://hg.mozilla.org/integration/autoland/rev/963798d98540
[wdspec] Add Element.screenshot() command to webdriver client. r=webdriver-reviewers,jgraham
https://hg.mozilla.org/integration/autoland/rev/bca8017c8461
[wdspec] Improve screenshot tests for checking the contents of frames. r=webdriver-reviewers,ato
Flags: needinfo?(nbeleuzu)
Status: ASSIGNED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
Upstream PR merged by moz-wptsync-bot
Flags: needinfo?(nbeleuzu)

Is this something you wanted to uplift to Beta for Fx73?

Flags: needinfo?(hskupin)

Yes, totally. Please uplift these test-only patch series to mozilla-beta.

Flags: needinfo?(hskupin)
Whiteboard: [checkin-needed-beta]

Please note that this might also need the patch on bug 1398087 to be uplifted first.

You need to log in before you can comment on or make changes to this bug.