Closed Bug 1607092 Opened 7 months ago Closed 12 days ago

Add new quote from Book of Mozilla for GeckoView

Categories

(Firefox :: General, enhancement)

Unspecified
All
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 80
Tracking Status
firefox80 --- fixed

People

(Reporter: jonalmeida, Assigned: jonalmeida)

References

Details

Attachments

(2 files, 2 obsolete files)

Originally filed in fenix#1398 it seems like GeckoView has it's own about:mozilla page from cpeterson's comment.

Although it would be better if the quote included all our GV browsers and not just one (Fenix, FxR, Focus/R-B?).

Seburo had interest in providing a quote as well.

Attached file The Book of Mozilla, 6 27.xhtml (obsolete) —

Please find attached my proposed wording.

It has been two years since the writers of the Book convened to publish another chapter so as to bring forth the wisdom of the Beast unto the masses. In that time, much study and meditation has gone into understanding the messages that the Beast passes unto the writers of the book, leading to the attached file being drafted. As tradition dictates, it maintains the form, length and style of those that have written chapters previously.

This text brings forth the Beasts teachings in respect of GeckoView in its many forms. Whilst the intention to land this chapter in Desktop (before the acolytes assist in its transition to the mobile platforms) may be seen as a bit odd, this is not without historical precedent and is in line with the Beasts teachings in respect of cross platform unity.

Feedback is welcome, for the Beast teaches us that teamwork and collaboration is vital to success, but there are one or two elements that should be seen as if they have come from the Beast itself. In contemplating this text it would be appreciated if this could be landed soon so as to spread the word of the Beast to as many as possible as soon as is practical.

Thank you.

Attached file The Book of Mozilla, 6 27.xhtml (obsolete) —

This second file corrects a small typo.

Attachment #9118959 - Attachment is obsolete: true

Moving this bug from Fenix to Firefox, as the aim is to land this in desktop before it then lands in the GeckoView products, thus spreading these new teachings among all of the followers of the Beast.

Product: GeckoView → Firefox

I believe that the file that needs to be altered is at toolkit/locales/en-US/chrome/global/mozilla.dtd. I have tried to create an updated .dtd file, but am not having much luck.

Comment on attachment 9118961 [details]
The Book of Mozilla, 6 27.xhtml

Text to be replaced to remove the repeated use of "forth" in the second sentence.
Attachment #9118961 - Attachment is obsolete: true

Corrected text attached.

Assignee: nobody → jonalmeida942

Ehsan, I see that you helped submit the last update, would you be interested in reviewing this as well?

Flags: needinfo?(ehsan)
Attachment #9158395 - Attachment description: Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=ehsan → Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=flod

flod, could you take another look at the patch? I updated the page to use Fluent, but I may have made mistakes since I'm not quite familiar with it yet.

Flags: needinfo?(ehsan) → needinfo?(francesco.lodolo)

No need to flag on Bugzilla, Phabricator is enough. I'll take a look at the Fluent file, but you'll need an actual dev to check the rest of the code.

Flags: needinfo?(francesco.lodolo)
Attachment #9158395 - Attachment description: Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=flod → Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=Pike,agi

It's a bit unclear to me how to make this test pass: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b2dfd2ae3019347e35839ab4c4362dcb073346b3&selectedTaskRun=cHuI2zbFROm043cVhCS5Ew.0

TEST-UNEXPECTED-FAIL | browser/components/sessionstore/test/browser_capabilities.js | Found a tab after previous test timed out: about:mozilla -

Aside from this, we just need to get a final approval on the patch.

We're probably not going to make it for the 79 release, but we can try to uplift this so that Fenix can pick it up in the next GV beta upgrade.

Fixed the test failures, so the patch should be fine to land: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6d88e67099742d3234e83a01d95893493d76913a

A final +1 from comms would be ideal.

Flags: needinfo?(mhoye)

(it's not an easter egg if you need to ask permission, also we never spoke, and I was never here.)

Pushed by jonalmeida942@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/fc1e5e4d5ed8
Add new quote from Book of Mozilla for GeckoView r=geckoview-reviewers,Pike,agi

removing NI and disappears in a cloud of smoke

Flags: needinfo?(mhoye)
Status: NEW → RESOLVED
Closed: 12 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80

Ignore this comment, made an error in the uplift request.

Comment on attachment 9158395 [details]
Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=Pike,agi

Beta/Release Uplift Approval Request

  • User impact if declined: None, this is an easter egg for the Fenix release that will ship with the beta version.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open about:mozilla, verify a new quote reference "6:27" is seen.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Changes to tests that rely on loading the about:mozilla page may be flaky.
  • String changes made/needed: None, GeckoView does not inherit the translation files from desktop.
Attachment #9158395 - Flags: approval-mozilla-beta?
Flags: qe-verify+

(In reply to Jonathan Almeida [:jonalmeida] from comment #20)

Comment on attachment 9158395 [details]
Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=Pike,agi

Beta/Release Uplift Approval Request

Merge day is on Jul 27, so this patch is already going to Beta in 48 hours.

String changes made/needed: None, GeckoView does not inherit the translation files from desktop.

This is not correct. This patch has new strings that impact localization, they're just not localized in GeckoView (they're in Gecko, currently in Nightly). This should ride the trains with 80.

Comment on attachment 9158395 [details]
Bug 1607092 - Add new quote from Book of Mozilla for GeckoView r=Pike,agi

Today is merge day so the uplift is is not necessary to have this patch in 80 beta, I don't think this should be uplifted before the merge.

Attachment #9158395 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.