Closed Bug 1607444 Opened 1 month ago Closed 1 month ago

ThreadSanitizer: data race [@ setGeneration] vs. [@ flagsDontCheckGeneration]

Categories

(Core :: JavaScript Engine, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla74
Tracking Status
firefox73 --- wontfix
firefox74 --- fixed

People

(Reporter: decoder, Assigned: jonco)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

The attached crash information was detected while running CI tests with ThreadSanitizer on mozilla-central revision 6989fcd6bab3.

I was under the impression that this was on file already, but I can't find it and it still seems to reproduce on latest builds. The trace below is from an older build because newer builds seem to have their second stack broken (it could also be that something in the second stack is suppressed so it only shows up if the stack is broken).

General information about TSan reports

Why fix races?

Data races are undefined behavior and can cause crashes as well as correctness issues. Compiler optimizations can cause racy code to have unpredictable and hard-to-reproduce behavior.

Rating

If you think this race can cause crashes or correctness issues, it would be great to rate the bug appropriately as P1/P2 and/or indicating this in the bug. This makes it a lot easier for us to assess the actual impact that these reports make and if they are helpful to you.

False Positives / Benign Races

Typically, races reported by TSan are not false positives [1], but it is possible that the race is benign. Even in this case it would be nice to come up with a fix if it is easily doable and does not regress performance. Every race that we cannot fix will have to remain on the suppression list and slows down the overall TSan performance. Also note that seemingly benign races can possibly be harmful (also depending on the compiler, optimizations and the architecture) [2][3].

[1] One major exception is the involvement of uninstrumented code from third-party libraries.
[2] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
[3] How to miscompile programs with "benign" data races: https://www.usenix.org/legacy/events/hotpar11/tech/final_files/Boehm.pdf

Suppressing unfixable races

If the bug cannot be fixed, then a runtime suppression needs to be added in mozglue/build/TsanOptions.cpp. The suppressions match on the full stack, so it should be picked such that it is unique to this particular race. The bug number of this bug should also be included so we have some documentation on why this suppression was added.

This seems to be to do with sharing self hosted functions between runtimes. Jan do you know what's going on here?

Flags: needinfo?(jdemooij)
Component: JavaScript: GC → JavaScript Engine

How do you feel about just not GC'ing the self-hosting zone until the runtime is destroyed? Or maybe forcing a GC once right after we're done initializing the s-h zone? I think it would prevent these issues and make things more robust.

Flags: needinfo?(jdemooij) → needinfo?(jcoppeard)

(In reply to Jan de Mooij [:jandem] from comment #3)
I like the idea of collecting it once at the start and then not touching again it until shutdown.

Assignee: nobody → jcoppeard
Flags: needinfo?(jcoppeard)
Priority: -- → P1

This mostly works but provokes a couple of jittest failures related to atom marking later on.

Attachment #9121319 - Attachment description: Bug 1607444 - WIP: Only collect the self hosting zone once at runtime initialization → Bug 1607444 - Only collect the self hosting zone once at runtime initialization r?jandem
Attachment #9121319 - Attachment description: Bug 1607444 - Only collect the self hosting zone once at runtime initialization r?jandem → Bug 1607444 - Only collect the self hosting zone once at runtime initialization r=jandem
Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c9e1dfd4ffb0
Only collect the self hosting zone once at runtime initialization r=jandem
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74
You need to log in before you can comment on or make changes to this bug.