Closed Bug 1607569 Opened 11 months ago Closed 2 months ago

Perma Tier 2 Fission devtools/client/webconsole leakcheck | tab 30848 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)

Categories

(DevTools :: Console, defect, P3)

defect

Tracking

(Fission Milestone:M7, firefox83 fixed)

RESOLVED FIXED
83 Branch
Fission Milestone M7
Tracking Status
firefox83 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, Whiteboard: dt-fission-m2-mvp)

Attachments

(3 files)

Filed by: rgurzau [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=283869273&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/TNQ-jQnATRGaccvcHHv7xA/runs/0/artifacts/public/logs/live_backing.log


[task 2020-01-07T19:23:42.411Z] 19:23:42 INFO - TEST-START | devtools/client/webconsole/test/browser/browser_webconsole_worklet_error.js

[task 2020-01-07T19:26:18.104Z] 19:26:18 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_utils_Sandbox
[task 2020-01-07T19:26:18.105Z] 19:26:18 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCWrappedJS
[task 2020-01-07T19:26:18.105Z] 19:26:18 INFO - TEST-INFO | leakcheck | tab leaked 1 xpcJSWeakReference
[task 2020-01-07T19:26:18.106Z] 19:26:18 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 30848 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)
[task 2020-01-07T19:26:18.106Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.108Z] 19:26:18 INFO - leakcheck | Processing leak log file /tmp/tmpSRN1A6.mozrunner/runtests_leaks_tab_pid4063.log
[task 2020-01-07T19:26:18.108Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.108Z] 19:26:18 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4063
[task 2020-01-07T19:26:18.109Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.109Z] 19:26:18 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-07T19:26:18.110Z] 19:26:18 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-07T19:26:18.110Z] 19:26:18 INFO - 0 |TOTAL | 41 0| 61051 0|
[task 2020-01-07T19:26:18.111Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.111Z] 19:26:18 INFO - nsTraceRefcnt::DumpStatistics: 997 entries
[task 2020-01-07T19:26:18.112Z] 19:26:18 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-07T19:26:18.112Z] 19:26:18 INFO - leakcheck | Processing leak log file /tmp/tmpSRN1A6.mozrunner/runtests_leaks_tab_pid2966.log
[task 2020-01-07T19:26:18.113Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.113Z] 19:26:18 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 2966
[task 2020-01-07T19:26:18.114Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.115Z] 19:26:18 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-07T19:26:18.116Z] 19:26:18 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-07T19:26:18.116Z] 19:26:18 INFO - 0 |TOTAL | 39 0| 74266 0|
[task 2020-01-07T19:26:18.117Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.117Z] 19:26:18 INFO - nsTraceRefcnt::DumpStatistics: 899 entries
[task 2020-01-07T19:26:18.118Z] 19:26:18 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-07T19:26:18.118Z] 19:26:18 INFO - leakcheck | Processing leak log file /tmp/tmpSRN1A6.mozrunner/runtests_leaks_tab_pid2167.log
[task 2020-01-07T19:26:18.118Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.119Z] 19:26:18 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 2167
[task 2020-01-07T19:26:18.119Z] 19:26:18 INFO -
[task 2020-01-07T19:26:18.120Z] 19:26:18 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-07T19:26:18.120Z] 19:26:18 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-07T19:26:18.121Z] 19:26:18 INFO - 0 |TOTAL | 41 0| 53023 0|
[task 2020-01-07T19:26:18.121Z] 19:26:18 INFO -

Summary: Intermittent leakcheck | tab 30848 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...) → Perma Tier 2 Fission leakcheck | tab 30848 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)
Flags: needinfo?(nchevobbe)

I'm not sure what's going on here.
In Bug 1603765 we split the big manifest had into 3 smaller ones.
So I guess this shifted something, somehow.
I'll investigate today.

Flags: needinfo?(nchevobbe)

There are 26 total failures in the last 7 days on linux1804-64 and linux64 debug builds.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=285740706&repo=mozilla-central&lineNumber=13176

[task 2020-01-21T10:27:13.400Z] 10:27:13 INFO - TEST-START | devtools/client/webconsole/test/browser/browser_console_webconsole_private_browsing.js
[task 2020-01-21T10:27:13.428Z] 10:27:13 INFO - GECKO(4564) | [Parent 4564, Main Thread] WARNING: NS_ENSURE_TRUE(GetWrapper()) failed: file /builds/worker/workspace/build/src/dom/ipc/JSWindowActor.cpp, line 61
[task 2020-01-21T10:27:13.453Z] 10:27:13 INFO - GECKO(4564) | [Child 4780: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7f09d5907800 == 2 [pid = 4780] [id = {465c9440-44b7-4650-917e-433b37a46518}]
[task 2020-01-21T10:27:13.453Z] 10:27:13 INFO - GECKO(4564) | [Child 4780: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 3 (0x7f09dc12d980) [pid = 4780] [serial = 38] [outer = (nil)]
[task 2020-01-21T10:27:13.453Z] 10:27:13 INFO - GECKO(4564) | [Child 4780, Main Thread] WARNING: NS_ENSURE_TRUE(mPresShell) failed: file /builds/worker/workspace/build/src/layout/base/nsPresContext.cpp, line 845
[task 2020-01-21T10:27:13.454Z] 10:27:13 INFO - GECKO(4564) | [Child 4780: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 4 (0x7f09da07a800) [pid = 4780] [serial = 39] [outer = 0x7f09dc12d980]
[task 2020-01-21T10:27:13.595Z] 10:27:13 INFO - GECKO(4564) | [Child 4780, Main Thread] WARNING: Trying to request nsIHttpChannel from DocumentChannel, this is likely broken: file /builds/worker/workspace/build/src/netwerk/ipc/DocumentChannel.cpp, line 63
[task 2020-01-21T10:27:13.603Z] 10:27:13 INFO - GECKO(4564) | [Child 4780: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 5 (0x7f09dad8ec00) [pid = 4780] [serial = 40] [outer = 0x7f09dc12d980]
[task 2020-01-21T10:27:13.827Z] 10:27:13 INFO - GECKO(4564) | [Parent 4564: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7fcb2f4d8000 == 8 [pid = 4564] [id = {ef1191c9-498f-473d-8a62-cac7ccede2eb}]
[task 2020-01-21T10:27:13.827Z] 10:27:13 INFO - GECKO(4564) | [Parent 4564: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 18 (0x7fcb2c852c40) [pid = 4564] [serial = 105] [outer = (nil)]

[task 2020-01-21T10:30:19.637Z] 10:30:19 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Utils
[task 2020-01-21T10:30:19.637Z] 10:30:19 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_utils_Sandbox
[task 2020-01-21T10:30:19.637Z] 10:30:19 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCWrappedJS
[task 2020-01-21T10:30:19.638Z] 10:30:19 INFO - TEST-INFO | leakcheck | tab leaked 1 xpcJSWeakReference
[task 2020-01-21T10:30:19.638Z] 10:30:19 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 31680 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)
[task 2020-01-21T10:30:19.638Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.639Z] 10:30:19 INFO - leakcheck | Processing leak log file /tmp/tmp0Ctix_.mozrunner/runtests_leaks_tab_pid4651.log
[task 2020-01-21T10:30:19.639Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.640Z] 10:30:19 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4651
[task 2020-01-21T10:30:19.640Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.642Z] 10:30:19 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-21T10:30:19.642Z] 10:30:19 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-21T10:30:19.643Z] 10:30:19 INFO - 0 |TOTAL | 27 0| 1729730 0|
[task 2020-01-21T10:30:19.643Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.643Z] 10:30:19 INFO - nsTraceRefcnt::DumpStatistics: 1045 entries
[task 2020-01-21T10:30:19.644Z] 10:30:19 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-21T10:30:19.644Z] 10:30:19 INFO - leakcheck | Processing leak log file /tmp/tmp0Ctix_.mozrunner/runtests_leaks_tab_pid4925.log
[task 2020-01-21T10:30:19.645Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.645Z] 10:30:19 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4925
[task 2020-01-21T10:30:19.645Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.646Z] 10:30:19 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-01-21T10:30:19.646Z] 10:30:19 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-01-21T10:30:19.647Z] 10:30:19 INFO - 0 |TOTAL | 38 0| 165330 0|
[task 2020-01-21T10:30:19.647Z] 10:30:19 INFO -
[task 2020-01-21T10:30:19.647Z] 10:30:19 INFO - nsTraceRefcnt::DumpStatistics: 681 entries
[task 2020-01-21T10:30:19.648Z] 10:30:19 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-01-21T10:30:19.648Z] 10:30:19 INFO - leakcheck | Processing leak log file /tmp/tmp0Ctix_.mozrunner/runtests_leaks_tab_pid4746.log

Nicholas are there any updates here?

Flags: needinfo?(nchevobbe)
Whiteboard: [stockwell needswork:owner]

Summary: Intermittent leakcheck ... → Perma Tier 2 Fission leakcheck ...
42 failures in 3773 pushes (0.011 failures/push) were associated with this bug in the last 7 days.

@ Bogdan, you changed this bug summary from "Intermittent" to "Perma", but there were only 42 failures in the last 7 days. Is this test failure really permanent? Does this affect both Fission and non-Fission tests? Or just Fission?

Also, do you when this DevTools test became tier 2? kmag says he thinks they used to be tier 1. We shouldn't downgrade Fission tests from tier 1 to 2, if possible.

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #3)

In Bug 1603765 we split the big manifest had into 3 smaller ones.
So I guess this shifted something, somehow.
I'll investigate today.

@ Nicolas, do you have any updates?

kmag on the DOM Fission teams says he can try to reproduce locally.

Tracking for Fission Nightly (M6)

Fission Milestone: --- → M6
Flags: needinfo?(btara)

(In reply to Chris Peterson [:cpeterson] from comment #6)

Summary: Intermittent leakcheck ... → Perma Tier 2 Fission leakcheck ...
42 failures in 3773 pushes (0.011 failures/push) were associated with this bug in the last 7 days.

@ Bogdan, you changed this bug summary from "Intermittent" to "Perma", but there were only 42 failures in the last 7 days. Is this test failure really permanent? Does this affect both Fission and non-Fission tests? Or just Fission?

Also, do you when this DevTools test became tier 2? kmag says he thinks they used to be tier 1. We shouldn't downgrade Fission tests from tier 1 to 2, if possible.

This is perma-failing on mozilla-central, tier2. It doesn't run by default on integration, the failures classified there were from backfills.
I tried to look for when this got moved to tier2, however i didn't find that info.

Currently there are 19 total failures in the last 7 days on linux1804-64 debug and as Bogdan mentioned above, seems to be from bug 1603765 based on retriggers.

Flags: needinfo?(btara)

This started with the switch to Ubuntu 18.04. The report claims each console test creates a hidden windows and docshell. Is that true or is the suite dragging the leaked one along?

Regressed by: 1608251

(In reply to Andreea Pavel [:apavel] from comment #7)

Also, do you when this DevTools test became tier 2? kmag says he thinks they used to be tier 1. We shouldn't downgrade Fission tests from tier 1 to 2, if possible.

This is perma-failing on mozilla-central, tier2. It doesn't run by default on integration, the failures classified there were from backfills.
I tried to look for when this got moved to tier2, however i didn't find that info.

Increasing priority (from P5 to P3) because Andreea says this tier-2 test is perma-failing on mozilla-central.

Priority: P5 → P3
Summary: Perma Tier 2 Fission leakcheck | tab 30848 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...) → Perma Tier 2 Fission devtools/client/webconsole leakcheck | tab 30848 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)

There are 23 total failures in the last 7 days on linux1804-64 debug.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=291510210&repo=mozilla-central&lineNumber=13727

[task 2020-03-03T22:30:06.168Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsWindowMemoryReporter
[task 2020-03-03T22:30:06.169Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents
[task 2020-03-03T22:30:06.169Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponentsBase
[task 2020-03-03T22:30:06.169Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Classes
[task 2020-03-03T22:30:06.170Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_Constructor
[task 2020-03-03T22:30:06.170Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Interfaces
[task 2020-03-03T22:30:06.170Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Results
[task 2020-03-03T22:30:06.171Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Utils
[task 2020-03-03T22:30:06.171Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_utils_Sandbox
[task 2020-03-03T22:30:06.171Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCWrappedJS
[task 2020-03-03T22:30:06.171Z] 22:30:06 INFO - TEST-INFO | leakcheck | tab leaked 1 xpcJSWeakReference
[task 2020-03-03T22:30:06.172Z] 22:30:06 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 31344 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)
[task 2020-03-03T22:30:06.172Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.172Z] 22:30:06 INFO - leakcheck | Processing leak log file /tmp/tmpHyQ6rB.mozrunner/runtests_leaks_tab_pid5131.log
[task 2020-03-03T22:30:06.173Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.173Z] 22:30:06 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 5131
[task 2020-03-03T22:30:06.173Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.174Z] 22:30:06 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-03-03T22:30:06.174Z] 22:30:06 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-03-03T22:30:06.174Z] 22:30:06 INFO - 0 |TOTAL | 38 0| 426987 0|
[task 2020-03-03T22:30:06.175Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.175Z] 22:30:06 INFO - nsTraceRefcnt::DumpStatistics: 900 entries
[task 2020-03-03T22:30:06.175Z] 22:30:06 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-03-03T22:30:06.176Z] 22:30:06 INFO - leakcheck | Processing leak log file /tmp/tmpHyQ6rB.mozrunner/runtests_leaks_tab_pid4985.log
[task 2020-03-03T22:30:06.176Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.177Z] 22:30:06 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 4985
[task 2020-03-03T22:30:06.177Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.178Z] 22:30:06 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-03-03T22:30:06.178Z] 22:30:06 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-03-03T22:30:06.179Z] 22:30:06 INFO - 0 |TOTAL | 27 0| 1709911 0|
[task 2020-03-03T22:30:06.180Z] 22:30:06 INFO -
[task 2020-03-03T22:30:06.180Z] 22:30:06 INFO - nsTraceRefcnt::DumpStatistics: 1048 entries

Whiteboard: [stockwell unknown] → [stockwell needswork:owner]

There are 24 total failures in the last 7 days on linux1804-64 and macosx1014-64 debug.

Chris do you know who can take a look at this since Nicolas has not replied yet?

Flags: needinfo?(cpeterson)

It looks like devtools/client/webconsole/test/browser/browser_console_devtools_loader_exception.js is the leaking test, from looking at two logs. I can also reproduce it locally on OSX.

Flags: needinfo?(cpeterson)
Flags: needinfo?(mmucci)

(In reply to Andrew McCreight [:mccr8] from comment #22)

It looks like devtools/client/webconsole/test/browser/browser_console_devtools_loader_exception.js is the leaking test, from looking at two logs. I can also reproduce it locally on OSX.

Marco, this DevTools test is reporting an intermittent leak when Fission is enabled. Can someone on the DevTools team please temporarily disable this test when Fission is enabled (with something like skip-if = fission && debug && (os == "mac" || os == "linux")) and then add fixing the leaks to your DevTools Fission backlog?

Thanks Chris. Moving the 'needinfo' to Alex to have a look at the test and any follow up bugs.

Flags: needinfo?(mmucci) → needinfo?(poirot.alex)

(In reply to Chris Peterson [:cpeterson] from comment #25)

Marco, this DevTools test is reporting an intermittent leak when Fission is enabled.

This isn't an intermittent leak, it is a permanent leak.

I looked at the cycle collector logs, and this is what was keeping one of the leaking XPCWNs alive:

0x12dba5980 [nsXPCWrappedJS (nsIConsoleListener)] --[mJSObj]--> 0x1a67715daec0 [JS Object (Object)] --[group_proto]--> 0x1a677157e780 [JS Object (Object)] --[destroy]--> 0x1e2332665140 [JS Object (Function - destroy)] --[fun_environment]--> 0x1a67715f1790 [JS Object (LexicalEnvironment)] --[**UNKNOWN SLOT 1**]--> 0x1e233265d380 [JS Object (Object)] --[define]--> 0x1a677159b510 [JS Object (Function - define)] --[fun_environment]--> 0x30642bfb5ac0 [JS Object (LexicalEnvironment)] --[jsmScope]--> 0x1a6771596780 [JS Object (Proxy)] --[proxy target]--> 0x1a677159f2c0 [JS Object (Object)] --[loader]--> 0x30642bf349c0 [JS Object (Object)] --[lazyServiceGetter]--> 0x30642bfb36c0 [JS Object (Function - defineLazyServiceGetter)] --[fun_environment]--> 0x30642bf784f0 [JS Object (LexicalEnvironment)] --[debuggerSandbox]--> 0x26734b8c300 [JS Object (Proxy)] --[proxy target]--> 0x26734b7a380 [JS Object (Sandbox)] --[C]--> 0x30642bf61460 [JS Object (nsXPCComponents_Utils)] --[js::GetObjectPrivate(obj)]--> 0x12c527040 [XPCWrappedNative (nsXPCComponents_Utils)]

This means that the object keeping all of the rest of the stuff alive is an nsIConsoleListener implemented in JS, and it is being held alive from C++. My guess is that this test is somehow failing to unregister a listener from the console service.

It looks like nsConsoleService clears out its references during shutdown (which is not entirely great...) so maybe it isn't the console service.

Ok, I looked at DMD, and it does seem like it is nsConsoleService::RegisterListener that is holding onto the XPCWJS. I'm not sure why it isn't getting cleared.

I see. nsConsoleService::Reset() clears the strong references from mMessages, but not mListeners. I'm not sure why that is. But anyways, this means my original theory, that something isn't unregistering a listener, is the likely explanation. I don't know know how this web console code is expecting to unregister.

Thanks a ton Andrew for reducing that down!
We can probably have a look at DevTools/webconsole code.

But I wish we could debug the GC as you did it here.
Is there any documentation on how to see and identify GC paths like the one you copied in Comment 27?

Flags: needinfo?(poirot.alex)

The steps I used are documented here: https://developer.mozilla.org/en-US/docs/Mozilla/Performance/DMD/Heap_Scan_Mode

Though it did require a little hacking on the C++ because --mode=scan doesn't seem to work with mach mochitest.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Flags: needinfo?(nchevobbe)

In the last 7 days there have been 20 occurrences on linux 64 debug.

Recent failure: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=295158549&repo=mozilla-central&lineNumber=11955

Nicolas, can you provide an update about this permanent failure?

Flags: needinfo?(nchevobbe)

Yes, I think I see why it's happening.
browser_console_devtools_loader_exception.js is testing the browser console, which connects to multiple targets (i.e. we're setting multiple event listeners).
But the test can run quite fast and then the destroy path does not care about removing the listeners (iirc, because the target are not fully "attached", even if the listeners are set).
I had a patch to try to wait properly for things, but still had intermittent failures. I can try to push the current patch, see if it does reduce the number of failure as a first step.

Flags: needinfo?(nchevobbe)

Nicolas did you push your patch?

Flags: needinfo?(nchevobbe)

In the Browser toolbox destroy function, we now wait for
any pending connection initialization promise.
In the test we close the browser toolbox at the end.
We also need to guard a few method in the connection proxy
to ensure the instances we use are still alive before using
them.

There are 23 failures associated to this bug in the last 7 days. These are occurring on linux1804-64 debug builds.

log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=299960980&repo=mozilla-central&lineNumber=15462
[task 2020-04-29T10:42:06.362Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 4 nsXPCComponents
[task 2020-04-29T10:42:06.362Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Classes
[task 2020-04-29T10:42:06.363Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_Constructor
[task 2020-04-29T10:42:06.363Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Interfaces
[task 2020-04-29T10:42:06.364Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Results
[task 2020-04-29T10:42:06.364Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Utils
[task 2020-04-29T10:42:06.365Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_utils_Sandbox
[task 2020-04-29T10:42:06.365Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCWrappedJS
[task 2020-04-29T10:42:06.366Z] 10:42:06 INFO - TEST-INFO | leakcheck | tab leaked 1 xpcJSWeakReference
[task 2020-04-29T10:42:06.367Z] 10:42:06 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 34800 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)
[task 2020-04-29T10:42:06.368Z] 10:42:06 INFO -
[task 2020-04-29T10:42:06.368Z] 10:42:06 INFO - leakcheck | Processing leak log file /tmp/tmpq82_Ig.mozrunner/runtests_leaks_tab_pid7768.log
[task 2020-04-29T10:42:06.369Z] 10:42:06 INFO -
[task 2020-04-29T10:42:06.369Z] 10:42:06 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7768
[task 2020-04-29T10:42:06.370Z] 10:42:06 INFO -
[task 2020-04-29T10:42:06.370Z] 10:42:06 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-04-29T10:42:06.371Z] 10:42:06 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-04-29T10:42:06.371Z] 10:42:06 INFO - 0 |TOTAL | 37 0| 211811 0|
[task 2020-04-29T10:42:06.372Z] 10:42:06 INFO -
[task 2020-04-29T10:42:06.372Z] 10:42:06 INFO - nsTraceRefcnt::DumpStatistics: 950 entries
[task 2020-04-29T10:42:06.373Z] 10:42:06 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-04-29T10:42:06.373Z] 10:42:06 INFO - leakcheck | Processing leak log file /tmp/tmpq82_Ig.mozrunner/runtests_leaks_tab_pid7548.log
[task 2020-04-29T10:42:06.374Z] 10:42:06 INFO -
[task 2020-04-29T10:42:06.374Z] 10:42:06 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7548

Nicholas any updates for this?

Alexandre, could you review the patch in this bug. It has reached the disable-recommended tag and fails only on linux1804-64 debug with fission.
Recent failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=301478093&repo=mozilla-central.

Flags: needinfo?(poirot.alex)

In the patch Nicholas mentions that the issue is not fixed.

Nicholas are there any updates here? Are you still working on this?

Flags: needinfo?(poirot.alex)
Flags: needinfo?(nchevobbe)
Flags: needinfo?(nchevobbe)
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]
See Also: → 1636817
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0be5f9822cad
Fix leak in browser_console_devtools_loader_exception. r=ochameau.

Sorry, I might have rushed into landing this because of the green try. I've backed it out just in case it needs more work: https://hg.mozilla.org/integration/autoland/rev/fc7877355ee59ed71ed5e7dfcc8d2a42a06d0d3e. Sorry for the trouble.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d803e87f7692
Fix leak in browser_console_devtools_loader_exception. r=ochameau.
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: Firefox 78 → ---
Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

There are 31 total failures in the last 7 days on linux1804-64 debug

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=302653999&repo=mozilla-central&lineNumber=16126

[task 2020-05-17T22:29:37.840Z] 22:29:37 INFO - TEST-START | devtools/client/webconsole/test/browser/browser_console_webconsole_private_browsing.js
[task 2020-05-17T22:29:37.941Z] 22:29:37 INFO - GECKO(6892) | [Child 6960: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7f32aac73c00 == 2 [pid = 6960] [id = {7a63cd0a-99f8-4b8d-8b80-2da1f16cb2a4}]
[task 2020-05-17T22:29:37.942Z] 22:29:37 INFO - GECKO(6892) | [Child 6960: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 3 (0x7f32c0893350) [pid = 6960] [serial = 45] [outer = (nil)]
[task 2020-05-17T22:29:37.943Z] 22:29:37 INFO - GECKO(6892) | [Child 6960: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 4 (0x7f32aac7f400) [pid = 6960] [serial = 46] [outer = 0x7f32c0893350]
[task 2020-05-17T22:29:37.963Z] 22:29:37 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 10 (0x7fe9bd182400) [pid = 7430] [serial = 2] [outer = (nil)] [url = about:blank]
[task 2020-05-17T22:29:37.964Z] 22:29:37 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7fe9b71bec00 == 0 [pid = 7430] [id = {c82ebb0c-2a56-40ab-b31d-3ab5f35a0c09}] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-console-iframes.html]
[task 2020-05-17T22:29:38.169Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 9 (0x7fe9d2c93350) [pid = 7430] [serial = 1] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-console-iframes.html]
[task 2020-05-17T22:29:38.169Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 8 (0x7fe9b713cd90) [pid = 7430] [serial = 6] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe3.html]
[task 2020-05-17T22:29:38.169Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 7 (0x7fe9b713cbc0) [pid = 7430] [serial = 5] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe2.html]
[task 2020-05-17T22:29:38.169Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 6 (0x7fe9b6d529a0) [pid = 7430] [serial = 10] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe1.html]
[task 2020-05-17T22:29:38.169Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 5 (0x7fe9b713c9f0) [pid = 7430] [serial = 4] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe1.html]
[task 2020-05-17T22:29:38.169Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 4 (0x7fe9bd185800) [pid = 7430] [serial = 11] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe1.html]
[task 2020-05-17T22:29:38.170Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 3 (0x7fe9b71c9800) [pid = 7430] [serial = 9] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe3.html]
[task 2020-05-17T22:29:38.172Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 2 (0x7fe9b71c7400) [pid = 7430] [serial = 8] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe2.html]
[task 2020-05-17T22:29:38.173Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 1 (0x7fe9b7158400) [pid = 7430] [serial = 7] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-iframe1.html]
[task 2020-05-17T22:29:38.174Z] 22:29:38 INFO - GECKO(6892) | [Child 7430: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 0 (0x7fe9bd189800) [pid = 7430] [serial = 3] [outer = (nil)] [url = http://example.com/browser/devtools/client/webconsole/test/browser/test-console-iframes.html]
[task 2020-05-17T22:29:38.175Z] 22:29:38 INFO - GECKO(6892) | [Child 7430, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005 (NS_ERROR_FAILURE): file /builds/worker/checkouts/gecko/netwerk/base/nsNetUtil.cpp, line 2295
[task 2020-05-17T22:29:38.176Z] 22:29:38 INFO - GECKO(6892) | [Child 7430, Main Thread] WARNING: 'NS_FAILED(rv)', file /builds/worker/checkouts/gecko/caps/ContentPrincipal.cpp, line 398

[task 2020-05-17T22:30:44.927Z] 22:30:44 INFO - nsTraceRefcnt::DumpStatistics: 879 entries
[task 2020-05-17T22:30:44.927Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 AtomTablesReporter
[task 2020-05-17T22:30:44.927Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 4 BackstagePass
[task 2020-05-17T22:30:44.928Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ChannelCountReporter
[task 2020-05-17T22:30:44.928Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 CondVar
[task 2020-05-17T22:30:44.929Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 DMDReporter
[task 2020-05-17T22:30:44.929Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 DOMEventListenerManagersHashReporter
[task 2020-05-17T22:30:44.929Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 DataStorageMemoryReporter
[task 2020-05-17T22:30:44.930Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 DeadlockDetectorReporter
[task 2020-05-17T22:30:44.930Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 GeckoProfilerReporter
[task 2020-05-17T22:30:44.931Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 GfxMemoryImageReporter
[task 2020-05-17T22:30:44.931Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 GfxTexturesReporter
[task 2020-05-17T22:30:44.931Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ICUReporter
[task 2020-05-17T22:30:44.932Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 IdlePeriod
[task 2020-05-17T22:30:44.932Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 IdleSchedulerChild
[task 2020-05-17T22:30:44.933Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 72 JS Object
[task 2020-05-17T22:30:44.933Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 JSMainRuntimeRealmsReporter
[task 2020-05-17T22:30:44.933Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 JSMainRuntimeTemporaryPeakReporter
[task 2020-05-17T22:30:44.934Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 JemallocHeapReporter
[task 2020-05-17T22:30:44.934Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 MemoryReportingMLGPU
[task 2020-05-17T22:30:44.935Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 MessageManagerReporter
[task 2020-05-17T22:30:44.935Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 12 Mutex
[task 2020-05-17T22:30:44.935Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 OggReporter
[task 2020-05-17T22:30:44.936Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 PIdleSchedulerChild
[task 2020-05-17T22:30:44.936Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 PageFaultsHardReporter
[task 2020-05-17T22:30:44.937Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 PageFaultsSoftReporter
[task 2020-05-17T22:30:44.937Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 PendingResponseReporter
[task 2020-05-17T22:30:44.937Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 PollableEvent
[task 2020-05-17T22:30:44.938Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 PreferenceServiceReporter
[task 2020-05-17T22:30:44.938Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 Preferences
[task 2020-05-17T22:30:44.939Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ResidentPeakReporter
[task 2020-05-17T22:30:44.939Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ResidentReporter
[task 2020-05-17T22:30:44.939Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ResidentUniqueReporter
[task 2020-05-17T22:30:44.940Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 SharedPrefMap
[task 2020-05-17T22:30:44.940Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ShmemReporter
[task 2020-05-17T22:30:44.940Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 SkMemoryReporter
[task 2020-05-17T22:30:44.941Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 SurfaceMemoryReporter
[task 2020-05-17T22:30:44.942Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 SystemHeapReporter
[task 2020-05-17T22:30:44.943Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 TelemetryImpl
[task 2020-05-17T22:30:44.943Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ThreadEventTarget
[task 2020-05-17T22:30:44.943Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ThreadTargetSink
[task 2020-05-17T22:30:44.944Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 ThreadsReporter
[task 2020-05-17T22:30:44.944Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 VsizeReporter
[task 2020-05-17T22:30:44.945Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 WeakReference<PIdleSchedulerChild>
[task 2020-05-17T22:30:44.945Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 WorkerDebuggerManager
[task 2020-05-17T22:30:44.946Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 31 XPCNativeInterface
[task 2020-05-17T22:30:44.946Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 31 XPCNativeMember
[task 2020-05-17T22:30:44.946Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 28 XPCNativeSet
[task 2020-05-17T22:30:44.948Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 45 XPCWrappedNative
[task 2020-05-17T22:30:44.948Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 25 XPCWrappedNativeProto
[task 2020-05-17T22:30:44.949Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 59 XPCWrappedNativeTearOff
[task 2020-05-17T22:30:44.949Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 gfxFontCache::MemoryReporter
[task 2020-05-17T22:30:44.949Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 gfxPlatformFontList::MemoryReporter
[task 2020-05-17T22:30:44.950Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 imgMemoryReporter
[task 2020-05-17T22:30:44.950Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 mozJSSubScriptLoader
[task 2020-05-17T22:30:44.950Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsCategoryObserver
[task 2020-05-17T22:30:44.951Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsComponentManagerImpl
[task 2020-05-17T22:30:44.951Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsConsoleService
[task 2020-05-17T22:30:44.951Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsDOMWindowUtils
[task 2020-05-17T22:30:44.952Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsHttpActivityDistributor
[task 2020-05-17T22:30:44.952Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsIOService
[task 2020-05-17T22:30:44.952Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsJSPrincipals
[task 2020-05-17T22:30:44.953Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsMemoryReporterManager
[task 2020-05-17T22:30:44.953Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsObserverService
[task 2020-05-17T22:30:44.954Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 2 nsPrefBranch
[task 2020-05-17T22:30:44.954Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsScriptSecurityManager
[task 2020-05-17T22:30:44.955Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsSocketTransportService
[task 2020-05-17T22:30:44.956Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsStreamTransportService
[task 2020-05-17T22:30:44.957Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1926 nsStringBuffer
[task 2020-05-17T22:30:44.957Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 28 nsTArray_base
[task 2020-05-17T22:30:44.957Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsThread
[task 2020-05-17T22:30:44.958Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsTimer
[task 2020-05-17T22:30:44.958Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsTimerImpl
[task 2020-05-17T22:30:44.959Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 13 nsWeakReference
[task 2020-05-17T22:30:44.959Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsWindowMediator
[task 2020-05-17T22:30:44.959Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsWindowMemoryReporter
[task 2020-05-17T22:30:44.960Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 4 nsXPCComponents
[task 2020-05-17T22:30:44.961Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Classes
[task 2020-05-17T22:30:44.961Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_Constructor
[task 2020-05-17T22:30:44.961Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Interfaces
[task 2020-05-17T22:30:44.962Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Results
[task 2020-05-17T22:30:44.962Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 3 nsXPCComponents_Utils
[task 2020-05-17T22:30:44.963Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCComponents_utils_Sandbox
[task 2020-05-17T22:30:44.963Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 nsXPCWrappedJS
[task 2020-05-17T22:30:44.963Z] 22:30:44 INFO - TEST-INFO | leakcheck | tab leaked 1 xpcJSWeakReference
[task 2020-05-17T22:30:44.964Z] 22:30:44 INFO - TEST-UNEXPECTED-FAIL | leakcheck | tab 35120 bytes leaked (AtomTablesReporter, BackstagePass, ChannelCountReporter, CondVar, DMDReporter, ...)
[task 2020-05-17T22:30:44.964Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.964Z] 22:30:44 INFO - leakcheck | Processing leak log file /tmp/tmp7TAbA0.mozrunner/runtests_leaks_tab_pid7052.log
[task 2020-05-17T22:30:44.964Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.965Z] 22:30:44 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7052
[task 2020-05-17T22:30:44.965Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.965Z] 22:30:44 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-05-17T22:30:44.965Z] 22:30:44 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-05-17T22:30:44.966Z] 22:30:44 INFO - 0 |TOTAL | 39 0| 540404 0|
[task 2020-05-17T22:30:44.966Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.966Z] 22:30:44 INFO - nsTraceRefcnt::DumpStatistics: 910 entries
[task 2020-05-17T22:30:44.967Z] 22:30:44 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-05-17T22:30:44.967Z] 22:30:44 INFO - leakcheck | Processing leak log file /tmp/tmp7TAbA0.mozrunner/runtests_leaks_tab_pid7076.log
[task 2020-05-17T22:30:44.968Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.968Z] 22:30:44 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7076
[task 2020-05-17T22:30:44.969Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.969Z] 22:30:44 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-05-17T22:30:44.970Z] 22:30:44 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-05-17T22:30:44.970Z] 22:30:44 INFO - 0 |TOTAL | 28 0| 1412977 0|
[task 2020-05-17T22:30:44.971Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.971Z] 22:30:44 INFO - nsTraceRefcnt::DumpStatistics: 1025 entries
[task 2020-05-17T22:30:44.972Z] 22:30:44 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-05-17T22:30:44.972Z] 22:30:44 INFO - leakcheck | Processing leak log file /tmp/tmp7TAbA0.mozrunner/runtests_leaks_tab_pid7123.log
[task 2020-05-17T22:30:44.973Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.973Z] 22:30:44 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7123
[task 2020-05-17T22:30:44.974Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.974Z] 22:30:44 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-05-17T22:30:44.975Z] 22:30:44 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-05-17T22:30:44.975Z] 22:30:44 INFO - 0 |TOTAL | 41 0| 39738 0|
[task 2020-05-17T22:30:44.976Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.976Z] 22:30:44 INFO - nsTraceRefcnt::DumpStatistics: 876 entries
[task 2020-05-17T22:30:44.977Z] 22:30:44 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-05-17T22:30:44.977Z] 22:30:44 INFO - leakcheck | Processing leak log file /tmp/tmp7TAbA0.mozrunner/runtests_leaks_tab_pid7365.log
[task 2020-05-17T22:30:44.978Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.979Z] 22:30:44 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 7365
[task 2020-05-17T22:30:44.979Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.979Z] 22:30:44 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-05-17T22:30:44.980Z] 22:30:44 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-05-17T22:30:44.981Z] 22:30:44 INFO - 0 |TOTAL | 24 0| 297426 0|
[task 2020-05-17T22:30:44.981Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.982Z] 22:30:44 INFO - nsTraceRefcnt::DumpStatistics: 859 entries
[task 2020-05-17T22:30:44.982Z] 22:30:44 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-05-17T22:30:44.983Z] 22:30:44 INFO - leakcheck | Processing leak log file /tmp/tmp7TAbA0.mozrunner/runtests_leaks_tab_pid6976.log
[task 2020-05-17T22:30:44.984Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.984Z] 22:30:44 INFO - == BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, tab process 6976
[task 2020-05-17T22:30:44.985Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.986Z] 22:30:44 INFO - |<----------------Class--------------->|<-----Bytes------>|<----Objects---->|
[task 2020-05-17T22:30:44.986Z] 22:30:44 INFO - | | Per-Inst Leaked| Total Rem|
[task 2020-05-17T22:30:44.987Z] 22:30:44 INFO - 0 |TOTAL | 43 0| 361504 0|
[task 2020-05-17T22:30:44.987Z] 22:30:44 INFO -
[task 2020-05-17T22:30:44.988Z] 22:30:44 INFO - nsTraceRefcnt::DumpStatistics: 890 entries
[task 2020-05-17T22:30:44.988Z] 22:30:44 INFO - TEST-PASS | leakcheck | tab no leaks detected!
[task 2020-05-17T22:30:44.989Z] 22:30:44 INFO - runtests.py | Running tests: end.

Note that bug 1636192's patch may have an impact on this leak as well.

Attachment #9151119 - Attachment description: Bug 1607569 - disable browser_console_webconsole_private_browsing.js on on linux18.04 fission debug r#?intermittent-reviewers → Bug 1607569 - disable browser_console_webconsole_private_browsing.js on on linux18.04 fission debug r=jmaher DONTBUILD

Alexandre, if you are working on this, please re-enable the test in your fix.

Flags: needinfo?(poirot.alex)
Keywords: leave-open
Whiteboard: [stockwell disable-recommended] → [stockwell disabled]
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/519535f418ad
disable browser_console_webconsole_private_browsing.js on on linux18.04 fission debug r=jmaher DONTBUILD

This test is still skipped for Fission on debug Linux:

https://searchfox.org/mozilla-central/rev/b4f3ce16c5099cf068fb023341959a0457adec9e/devtools/client/webconsole/test/browser/_browser_console.ini#47-48

https://searchfox.org/mozilla-central/rev/b4f3ce16c5099cf068fb023341959a0457adec9e/devtools/client/webconsole/test/browser/_browser_console.ini#47-48

Adding dt-fission whiteboard tag to DevTools bugs that mention Fission or block Fission meta bugs but don't already have a dt-fission whiteboard tag.

Assignee: nchevobbe → nobody
Fission Milestone: M6 → M7
Whiteboard: [stockwell disabled] → [stockwell disabled] dt-fission

Nicolas, you fixed browser_console_devtools_loader_exception.js in this bug, but later on browser_console_webconsole_private_browsing.js has been disabled for similar reasons.
Do you think it would require a similar fix ?

(Moving the bug to the reserve list to give it slightly move visibility)

Flags: needinfo?(poirot.alex)
Whiteboard: [stockwell disabled] dt-fission → [stockwell disabled] dt-fission-m2-reserve

(In reply to Alexandre Poirot [:ochameau] from comment #69)

Nicolas, you fixed browser_console_devtools_loader_exception.js in this bug, but later on browser_console_webconsole_private_browsing.js has been disabled for similar reasons.
Do you think it would require a similar fix ?

(Moving the bug to the reserve list to give it slightly move visibility)

maybe, I'll give it a try

Assignee: nobody → nchevobbe
Flags: needinfo?(nchevobbe)
Attachment #9176853 - Attachment description: Bug 1607569 - Fix intermittent leak in browser_console_webconsole_private_browsing.js. r=ochameau. → Bug 1607569 - Re-enable browser_console_webconsole_private_browsing.js. r=ochameau.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a79e5aa67bee
Re-enable browser_console_webconsole_private_browsing.js. r=ochameau.
Keywords: leave-open
Whiteboard: [stockwell disabled] dt-fission-m2-reserve → dt-fission-m2-reserve
Status: REOPENED → RESOLVED
Closed: 7 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
Whiteboard: dt-fission-m2-reserve → dt-fission-m2-mvp
You need to log in before you can comment on or make changes to this bug.