Closed Bug 1607768 Opened 3 months ago Closed 3 months ago

Thunderbird should check for add-on updates immediately after the TB version is updated

Categories

(Thunderbird :: Add-Ons: General, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1574183

People

(Reporter: jik, Unassigned)

Details

When someone upgrades TB, and the new TB version requires a new version of an add-on, then that add-on suddenly becomes incompatible and disabled in TB until TB gets around to checking for add-on updates.

People keep asking me "when are you going to make your add-on compatible with TB 68" when it already is and TB just hasn't updated it yet.

This became a much bigger problem starting with TB 68 because so many add-ons require separate XPIs for TB 60 vs. TB 68, and indeed, the recommendation that was made to add-on maintainers was that trying to make XPIs that are compatible with both TB 60 and TB 68 is discouraged.

This is going to be a big problem with the jump from TB 68 to TB 78 as well, given that every add-on is going to have to be converted to a MailExtension.

The fix for this is to have TB check for add-on updates on startup whenever it is upgraded, and if a restart is required after the updates are downloaded, pop up a message telling the user that.

It is certainly a significant support issue.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1574183
You need to log in before you can comment on or make changes to this bug.