Closed Bug 160816 Opened 21 years ago Closed 18 years ago

This URL hangs Mozilla, but not IE (nsCellMap::GetDataAt issue)

Categories

(Core :: Layout: Tables, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME
Future

People

(Reporter: skyman, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: hang, perf, testcase)

Attachments

(2 files)

My mozilla hangs when going to this URL (VERSION 1.0/WIN XP).
it seems that it's looping here :
nsTableRowGroupFrame::CalculateRowHeights(nsIPresContext * 0x05bd9658,
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, nsTableRowFrame *
0x00000000) line 698 + 15 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x0721c038,
nsIPresContext * 0x05bd9658, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1239

-> Html Tables
Assignee: Matti → karnaze
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: Browser-General → HTMLTables
Ever confirmed: true
Keywords: hang
QA Contact: asa → amar
A profile shows us using 95% of out pageload time in
nsCellMap::GetDataAt(nsTableCellMap &, int, int, int)
Keywords: perf
Summary: This URL hangs Mozilla, but not IE → This URL hangs Mozilla, but not IE (nsCellMap::GetDataAt issue)
it also hangs on sparc with 20020804 .
so change its platform as all
OS: Windows XP → All
Hardware: PC → All
Attached file testcase
the first td  set its colspan as 1078, that is the problem, 
if remove it , it is ok.

Other tr has only one td, so set colspan as 1078 has no sense.
seems like html code error.
Attached file hang testcase
sorry for my mistake, this new one is hang testcase.
testcase 94285 show the differenct of mozilla and IE.

*** This bug has been marked as a duplicate of 86293 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
this is not a dupe
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Priority: -- → P3
Target Milestone: --- → Future
Blocks: 198827
Keywords: testcase
*** Bug 198827 has been marked as a duplicate of this bug. ***
No longer blocks: 198827
mass reassign to default owner
Assignee: karnaze → table
Status: REOPENED → NEW
QA Contact: amar → madhur
Target Milestone: Future → ---
Target Milestone: --- → Future
*** Bug 214370 has been marked as a duplicate of this bug. ***
Blocks: 203448
Blocks: 220997
Blocks: 233311
Blocks: 234240
*** Bug 261966 has been marked as a duplicate of this bug. ***
The "hang testcase" hangs Mozilla1.7, but loads instantly in current trunk build.
Is this bug WFM, now?
I love it when difficult to debug hangs go WFM
Status: NEW → RESOLVED
Closed: 21 years ago18 years ago
Resolution: --- → WORKSFORME
but we need to reopen the still hanging dups
You need to log in before you can comment on or make changes to this bug.