Closed Bug 1609075 Opened 3 years ago Closed 2 years ago

Lots of "Ignored system principal in getEmbedderElement!" logged to console when using browser toolbox's inspect tool with browser.xhtml

Categories

(DevTools :: Framework, defect)

defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox72 unaffected, firefox73 unaffected, firefox74 fixed)

RESOLVED FIXED
Firefox 74
Tracking Status
firefox-esr68 --- unaffected
firefox72 --- unaffected
firefox73 --- unaffected
firefox74 --- fixed

People

(Reporter: Gijs, Assigned: ochameau)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Open Firefox
  2. Use shortcut to open browser toolbox
  3. use the inspect tool in the inspector to pick an element in browser chrome to inspect

What happened?

"Ignored system principal in getEmbedderElement!" gets logged to the console for every element I hover over.

What should have happened?

Not so much logging.

Alex, do you think we should bring this one in to the DevTools Fission M2 project backlog? Seems like we should fix it sooner rather than later.

Flags: needinfo?(poirot.alex)
Assignee: nobody → poirot.alex
Flags: needinfo?(poirot.alex)
URL: 1579042

Sorry for this error spam and the lag for looking into see.

Bug 1579042 should address the underlying issue, but it is going to take some time.
So it is propably better to silence this error in the meantime.

This error should hopefully be addressed in bug 1579042.

Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97335697ba00
Silence the getEmbedderElement error message. r=jdescottes
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.