Closed Bug 1579042 Opened 3 years ago Closed 2 years ago

Introduce TabDescriptors

Categories

(DevTools :: General, task, P1)

task

Tracking

(Fission Milestone:M6, firefox75 fixed)

RESOLVED FIXED
Firefox 75
Fission Milestone M6
Tracking Status
firefox75 --- fixed

People

(Reporter: yulia, Assigned: jdescottes)

References

(Blocks 3 open bugs, Regressed 1 open bug)

Details

(Whiteboard: dt-fission-m2-mvp )

Attachments

(6 files, 4 obsolete files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

Similar to processDescriptors and frameDescriptors, we want to be able to have descriptors for tabs.

Priority: -- → P2
Summary: Introduce TabDescrptors → Introduce TabDescriptors

Depends on D49454

Depends on D49455

Blocks: 1600612
Assignee: nobody → jdescottes
Status: NEW → ASSIGNED
Depends on: 1602371
Whiteboard: dt-fission-m2-mvp
Priority: P2 → P1

Tracking DevTools bugs for Fission Nightly (M6) milestone

Fission Milestone: --- → M6
Depends on: 1616224

Depends on D63503

Fix another test


Fix getTab


Investigate listTabs issues for about debugger


prettier on actors/descriptors/tab


Fix race condition in selectRuntime helper after making watchRuntime more async


Bail out of listTabs if root front was destroyed


Reject tab descriptor update request if the tab is closed


Return empty array instead of null when listTabs fails


WIP : Do not destroy tab descriptor front on exited event


Wait for the toolbox tab to disappear in aboutdebugging target destroyed test


Stop using attach in browser_dbg_listtabs-01 because tab targets are automatically attached now

Attachment #9127866 - Attachment description: Bug 1579042 - Folded patch of all fixes required to fix intermittents after introducing tab descriptors → Bug 1579042 - Fix race condition in tests after introducing tab descriptors
Attachment #9101607 - Attachment is obsolete: true
Attachment #9101608 - Attachment is obsolete: true
Attachment #9101609 - Attachment is obsolete: true
Attachment #9101607 - Attachment is obsolete: false
Attachment #9101607 - Attachment is obsolete: true
Attachment #9101608 - Attachment is obsolete: false
Attachment #9101608 - Attachment is obsolete: true

DAMP comparison: https://treeherder.mozilla.org/perf.html#/comparesubtest?originalProject=try&newProject=try&newRevision=cdc90bf1ef41ff2707a4013b40285f2754cce18b&originalSignature=1759151&newSignature=1759151&framework=12&originalRevision=ba5e43db5d71c37d83d184bbaa9971f7aec30c85

  • cold.inspector.open.DAMP 5.4% slower
  • cold.netmonitor.open.DAMP 2.5% slower
  • cold.webconsole.open.DAMP 4.2% slower
  • complicated.netmonitor.open.DAMP 2.6% slower
  • simple.styleeditor.open.DAMP 3.8% slower
  • simple.webconsole.close.DAMP 6.8% slower
  • simple.webconsole.open.DAMP 2.6% slower
Blocks: 1618691
Blocks: 1618693
Blocks: 1618695
Blocks: 1618698
Blocks: 1618699
Attachment #9128556 - Attachment is obsolete: true
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2640fedd4b7d
Rename FrameTargetProxyActor to TabDescriptorActor r=ochameau
https://hg.mozilla.org/integration/autoland/rev/4001ef023857
migrate TabDescriptorActor to a protocol.js actor r=ochameau
https://hg.mozilla.org/integration/autoland/rev/7209387fd76b
Move tab call to getTarget from the server to the client r=ochameau
https://hg.mozilla.org/integration/autoland/rev/15ab7909725f
Return threadActor in browsing context form updates r=ochameau
https://hg.mozilla.org/integration/autoland/rev/b70997375b03
Fix race condition in tests after introducing tab descriptors r=ochameau
https://hg.mozilla.org/integration/autoland/rev/545bbdbc329e
Test tab descriptor in browser_target_parents.js r=ochameau
Regressions: 1618888

There is already a ni? in the other bug.

Flags: needinfo?(jdescottes)
Depends on: 1619718
Blocks: 1619720
Depends on: 1620046
Regressions: 1621651
You need to log in before you can comment on or make changes to this bug.