Closed Bug 1609815 Opened 9 months ago Closed 7 months ago

Remove Web Replay

Categories

(Core Graveyard :: Web Replay, task)

task
Not set
normal

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: bhackett1024, Assigned: jlast)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [ci-costs-2020:done])

Attachments

(4 files, 1 obsolete file)

I was laid off yesterday, and web replay seems like it should be removed from the tree now. I will not be around/able to maintain it, so unless someone else wants to make the effort to maintain it, pretty soon it will break and stay broken.

The attached patch removes all the replay related code I could find, and applies onto 893e9fda4bf3. I can't break this up and submit it for review because my phabricator account has been disabled, so someone else will need to get this landed.

For anyone wondering, I will be forking Gecko and continuing to develop web replay in a new tree. I've started https://webreplay.org/ for this effort.

Attached patch patch (893e9fda4bf3) (obsolete) — Splinter Review

I can try landing this.

I'm sorry to see you go Brian, but happy that users will have an opportunity to experience Web Replay in the near future.

Attachment #9121426 - Attachment is obsolete: true

I'm sorry to hear that you are leaving, Brian. Good luck with your continuing work on Web Replay. It is really neat.

(In case you don't know, you can set Bugzilla to block needinfos of you.)

Thanks for all your work on this Brian. Watching you bring this from a crazy tech idea to this blazing-fast user-ready experience has been an amazing journey and I am honored that I could work with you on it.

It's Web Replay's nature to never go away but to evolve, so thanks for pushing on with it and best of luck!

r+ for my parts, but I'd like to see some management sign-off on ripping this out.

Blocks: 1610333
Blocks: 1610335

(In reply to Jeff Gilbert [:jgilbert] from comment #8)

r+ for my parts, but I'd like to see some management sign-off on ripping this out.

This sounds like a reasonable request. I'll see what Jason thinks about it.

I think that is reasonable.

It's sad to see this removal but, I think it's the right way to go so, OK for me.
Andrew can you please confirm?

Honza

Flags: needinfo?(overholt)

Confirmed (and confirmed with a few others), thank you.

Flags: needinfo?(overholt)
Attachment #9122358 - Attachment description: Bug 1609815 - Remove Web Replay. r=loganfsmyth → Bug 1609815 - Remove Web Replay UI. r=loganfsmyth
Blocks: 1609783
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c41e5432b3c5
Remove Web Replay UI. r=loganfsmyth
Blocks: 1602635
Duplicate of this bug: 1602638
Blocks: 1612807

Jason: Please note that bug 1252803 just landed, so you'll have a little bitrot on the .eslintignore file to update as well.

Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cfe2388a674e
Remove Web Replay UI. r=loganfsmyth
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e8342190e430
Remove Web Replay UI. r=loganfsmyth
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Status: RESOLVED → REOPENED
Keywords: leave-open
Resolution: FIXED → ---
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/487a1fa09d0c
Remove unused devtools/client/webreplay reference from .eslintignore. r=mccr8

== Change summary for alert #24935 (as of Fri, 14 Feb 2020 04:51:24 GMT) ==

Improvements:

0.21% installer size osx-shippable opt nightly 80,459,534.92 -> 80,294,078.50

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=24935

Regressions: 1615611

Does this still need to have leave-open?

(In reply to Andreea Pavel [:apavel] from comment #29)

Does this still need to have leave-open?

There's still a lot of Web Replay to be removed. The patch that landed only removed the JS part of it.

(In reply to Andrew McCreight [:mccr8] from comment #30)

(In reply to Andreea Pavel [:apavel] from comment #29)

Does this still need to have leave-open?

There's still a lot of Web Replay to be removed. The patch that landed only removed the JS part of it.

Oh okay, thanks.

(In reply to Andrew McCreight [:mccr8] from comment #30)

(In reply to Andreea Pavel [:apavel] from comment #29)

Does this still need to have leave-open?

There's still a lot of Web Replay to be removed. The patch that landed only removed the JS part of it.

Is it OK to land something that breaks WebReplay or removes some WebReplay calls at this time?

Yes

Flags: needinfo?(jlaster)
Assignee: bhackett1024 → jlaster
Whiteboard: [ci-costs-2020:done]
Blocks: 1618379
Attachment #9121430 - Attachment description: Bug 1609815 - Remove Web Replay. r=loganfsmyth → Bug 1609815 - Remove Web Replay C++ implementation.

I've rebased the remainder of the patch.

Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d407a28318e6
Remove Web Replay C++ implementation. r=jgilbert,jandem,gbrown
Keywords: leave-open
Flags: needinfo?(jlaster) → needinfo?(continuation)

netwerk/base/nsSocketTransportService2.h is missing a #include <mozilla/Maybe.h>. The Maybe was introduced in bug 1596799.

(In reply to Mike Hommey [:glandium] from comment #37)

netwerk/base/nsSocketTransportService2.h is missing a #include <mozilla/Maybe.h>. The Maybe was introduced in bug 1596799.

Thanks, Mike. Yeah, a few places were bootlegging Maybe<> from WebReplay headers. I'll see if a Windows build finishes, then try to land it again.

Flags: needinfo?(continuation)
Pushed by amccreight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/954d5a7490a3
Remove Web Replay C++ implementation. r=jgilbert,jandem,gbrown
Status: REOPENED → RESOLVED
Closed: 8 months ago7 months ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
Depends on: 1648740
You need to log in before you can comment on or make changes to this bug.