Closed Bug 1610999 Opened 6 months ago Closed 5 months ago

Port |Bug 1392221 - FeedWriter doesn't implement nsINavHistoryObserver nor does it need to - so remove it from the QI definition| to SeaMonkey

Categories

(SeaMonkey :: Feed Discovery and Preview, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey 2.71

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

FeedWriter is declaring that it implements Ci.nsINavHistoryObserver, but it doesn't need to, nor does it implement it.
Bug 627416 stopped FeedWriter being an observer of Places history, and removed the implementation of that observer, but didn't remove the declaration line.
We can simply remove the line from the QueryInterface definition.

Applies cleanly on all repos

Attachment #9122512 - Flags: review?(frgrahl)
Attachment #9122512 - Flags: approval-comm-release+
Attachment #9122512 - Flags: approval-comm-esr60+
Comment on attachment 9122512 [details] [diff] [review]
Port simple removal

[Approval Request Comment]
Regression caused by (bug #): 627416
User impact if declined: None
Testing completed (on m-c, etc.): all
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #9122512 - Flags: approval-comm-release?
Attachment #9122512 - Flags: approval-comm-release+
Attachment #9122512 - Flags: approval-comm-esr60?
Attachment #9122512 - Flags: approval-comm-esr60+
Blocks: 1611010
Comment on attachment 9122512 [details] [diff] [review]
Port simple removal

LGTM
Attachment #9122512 - Flags: review?(frgrahl)
Attachment #9122512 - Flags: review+
Attachment #9122512 - Flags: approval-comm-release?
Attachment #9122512 - Flags: approval-comm-release+
Attachment #9122512 - Flags: approval-comm-esr60?
Attachment #9122512 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/2bd348484d80
Port |Bug 1392221 - FeedWriter doesn't implement nsINavHistoryObserver nor does it need to - so remove it from the QI definition| to SeaMonkey. r=frg

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.71
You need to log in before you can comment on or make changes to this bug.