Closed Bug 1611257 Opened 9 months ago Closed 9 months ago

Bugmail is being filtered incorrectly since this morning's BMO deployment

Categories

(bugzilla.mozilla.org :: Email Notifications, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: aklotz, Assigned: dkl)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review

Courtesy of tdsmith on Slack:

Bugzilla dupes the headers into the body of the message so that Gmail can see them; they’re being rendered as X-Bugzilla-Component: =3D?UTF-8?Q?CA_Certificate_Compliance?=3D now, which is confusing my filter

This is because we are not removing the special encoding from the header values before injecting into the email body itself.

Patch coming up.

Assignee: nobody → dkl
Status: NEW → ASSIGNED
Attached file GitHub Pull Request

Merged to master. Deploy coming soon.

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1611269
Duplicate of this bug: 1611494

Can you post here when this is deployed? I suspect bug 1611494 is not actually a dupe of this bug based on comment 1 and what the patch appears to be doing.

Flags: needinfo?(dkl)
Flags: needinfo?(dkl)
You need to log in before you can comment on or make changes to this bug.