Closed Bug 1611900 Opened 3 years ago Closed 3 years ago

Autucomplete dropdown is toggled and dismissed multiple times on mail.ru login form

Categories

(Toolkit :: Password Manager: Site Compatibility, defect)

Desktop
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1610539

People

(Reporter: tbabos, Unassigned)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(2 files)

Attached video Recording of the issue

Affected platforms:
Mac OS 10.15
Ubuntu 18.04
Windows 10

Affected versions:
Nightly 74
Beta 73.0b10
Release 72.0.2 (64-bit)

Last good version:
FX71.0a1 2019-10-09

Steps to reproduce:

  1. Launch Firefox
  2. Go to mail.ru and save 2 set of credentials
  3. Reload mail.ru
  4. Select any of the saved username and continue
  5. Delete the filled in password to toggle the autocomplete dropdown
    5.1 Go back to the username form and choose to continue to the password form

Expected:
The autocomplete dropdown should be toggled and remain displayed until the username/password field will be unfocused

Actual:
The autocomplete dropdown is toggled and dismissed several times

Regression-Range:
27:26.96 INFO: Last good revision: 6b9df1cffc79c4a0ee61f5c3f8677722aa4193a0
27:26.96 INFO: First bad revision: 25ba54160c0aee63142e87bf06e67b92c89f566a
Regressed by: Bug 1573836

Browser log:
See attachment. "Creating new autocomplete search result" log appears for each toggle/dismiss

Attached file AutocompleteLog.txt

Hi Neal, please take a look at this when you have the time for it, thanks!

Flags: needinfo?(enndeakin)

Pretty sure this is the same issue as 1610539.

Depends on: 1610539
Flags: needinfo?(enndeakin)

(In reply to Neil Deakin from comment #3)

Pretty sure this is the same issue as 1610539.

That's right, this was also fixed by the fix landed for Bug 1610539. Duplicating it to 1610539.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1610539
Blocks: 1585952
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.