Closed Bug 1611914 Opened 9 months ago Closed 7 months ago

Don't re-authenticate the user to view saved passwords shortly after the previous prompt

Categories

(Firefox :: about:logins, enhancement, P2)

72 Branch
enhancement

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox75 --- wontfix
firefox76 --- verified

People

(Reporter: nigel.hawkins, Assigned: jaws)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

Steps to reproduce:

  1. From the menu, click "Logins and Passwords"
  2. select a login from the list on the left.
  3. Click the eye next to the masked password.
  4. Enter master password.
  5. Select another saved login.

Actual results:

Was asked for master password a second time.

Expected results:

Master password should have been remembered so that I can see all password without having to re-enter it every time.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Password Manager
Product: Firefox → Toolkit
Component: Password Manager → about:logins
Product: Toolkit → Firefox

The priority flag is not set for this bug.
:MattN, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(MattN+bmo)
Status: UNCONFIRMED → NEW
Type: defect → enhancement
Ever confirmed: true
Flags: needinfo?(MattN+bmo) → qe-verify+
Priority: -- → P3
Summary: Can't see all saved passwords at once. → Don't re-prompt for a master password within N seconds of re-authenticating with it
Duplicate of this bug: 1616891

My understanding is that this is in scope for releasing OS re-auth.

Priority: P3 → P2
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Duplicate of this bug: 1620908
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/66b802c651c4
Don't reprompt for OS auth after a successful authentication for 5 minutes or if the about:logins page is reloaded. r=MattN
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0ef46ae3853
Don't reprompt for OS auth after a successful authentication for 5 minutes or if the about:logins page is reloaded. r=MattN

Backed out 2 changesets (bug 1611914, bug 1605494) for causing browser chrome failures at browser/components/aboutlogins/tests/browser/browser_osAuthDialog.js

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=293696648&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=b0ef46ae385361a8eac610adc5e1801117afe838

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=293696648&repo=autoland&lineNumber=1970

Backout link: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=293696648&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=e9d4c770a20ce4d154d0d40ca436363db4ba533e

[task 2020-03-18T16:27:44.202Z] 16:27:44     INFO - Leaving test bound setup
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - Entering test bound test
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - updatechannel: nightly-autoland; platform: macosx
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - TEST-PASS | browser/components/aboutlogins/tests/browser/browser_osAuthDialog.js | skipping test since oskeystore cannot be automated in this environment - 
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - Buffered messages finished
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - TEST-UNEXPECTED-FAIL | browser/components/aboutlogins/tests/browser/browser_osAuthDialog.js | Test timed out - 
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - Console message: SENTINEL
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - GECKO(1848) | MEMORY STAT | vsize 7605MB | residentFast 349MB | heapAllocated 110MB
[task 2020-03-18T16:27:44.203Z] 16:27:44     INFO - TEST-OK | browser/components/aboutlogins/tests/browser/browser_osAuthDialog.js | took 45069ms
[task 2020-03-18T16:27:44.204Z] 16:27:44     INFO - checking window state
[task 2020-03-18T16:27:44.204Z] 16:27:44     INFO - GECKO(1848) | must wait for focus
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - Buffered messages finished
[task 2020-03-18T16:33:54.214Z] 16:33:54    ERROR - TEST-UNEXPECTED-TIMEOUT | browser/components/aboutlogins/tests/browser/browser_osAuthDialog.js (finished) | application timed out after 370 seconds with no output
[task 2020-03-18T16:33:54.214Z] 16:33:54    ERROR - Force-terminating active process(es).
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - Determining child pids from psutil...
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - [1850, 1849, 1852, 1853, 1854, 1855, 1856, 1857, 1858, 1851]
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1849
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1850
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1851
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1852
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1853
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1854
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1855
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1856
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1857
[task 2020-03-18T16:33:54.214Z] 16:33:54     INFO - ==> process 1848 launched child process 1858
[task 2020-03-18T16:33:54.219Z] 16:33:54     INFO - Found child pids: set([1856, 1857, 1858, 1849, 1850, 1851, 1852, 1853, 1854, 1855])
[task 2020-03-18T16:33:54.219Z] 16:33:54     INFO - Killing process: 1856
[task 2020-03-18T16:33:54.219Z] 16:33:54     INFO - Not taking screenshot here: see the one that was previously logged
Flags: needinfo?(jaws)
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6602d2f838c5
Don't reprompt for OS auth after a successful authentication for 5 minutes or if the about:logins page is reloaded. r=MattN
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

I have verified this issue and the master password or the OS auth is not triggered after a successful authentication for 5 minutes. The master password or OS auth is correctly triggered if the "about:logins" page is refreshed or the it's closed and reopened.

  • I have tested this using the latest Nightly 76.0a1 build (Build ID: 20200319215651)on Windows 10 x64, Windows 7 x64, Windows 8.1 Pro, Mac 10.15.3, Mac 10.14.6 and Arch Linux.
Status: RESOLVED → VERIFIED
Summary: Don't re-prompt for a master password within N seconds of re-authenticating with it → Don't re-authenticate the user to view saved passwords shortly after the previous prompt
You need to log in before you can comment on or make changes to this bug.