Page with many small inline images displays very slowly

VERIFIED DUPLICATE of bug 17265

Status

()

P3
normal
VERIFIED DUPLICATE of bug 17265
19 years ago
19 years ago

People

(Reporter: mpalczew, Assigned: karnaze)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I am using an Oct 11 nightly build of mozilla.  I went to the followind websites http://www.cs.wustl.edu/~sth2/gnome-icons/icon-page-gif.html http://www.cs.wustl.edu/~sth2/gnome-icons/icon-page-png.html
when I went to both I experienced massive slowdowns in all browser windows.  I was using apprunner.  I would assume that this is not a png problem because the gif version didn't work either.

Updated

19 years ago
QA Contact: leger → elig
Summary: Page with many small inline images displays very slow

Updated

19 years ago
Assignee: don → pnunn
Component: Browser-General → ImageLib

Comment 1

19 years ago
Hey, Pam ---

Not sure if this is compositor or imagelib, so it goes to you first. ;)

The page here draws very slowly --- background is drawn, then there's a ~90
second pause, and then it draws the page content and inline images. This also
occurs on Win32 (using today's build).

A similar (but only 10-15 second) slowdown occurs using Communicator 4.7. IE
displays it in under 2-3 seconds.

Comment 2

19 years ago
mpalczew, thanks for the bug! In the future, it helps if you read and follow the
Bug Writing Guidelines at http://www.mozilla.org/quality/bug-writing-
guidelines.html.

Updated

19 years ago
Summary: Page with many small inline images displays very slow → Page with many small inline images displays very slowly

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
I couldn't see the above page but the page
http://siesta.cs.wustl.edu/~sth2/gnome-icons/icons-gif.html
was still active.

All of these zillions of images are in a nested table and the
align=center is set for all of them. I believe layout would have
to survey the whole table, get each image's dimensions and calculate
the table layout.

This page is slow on 4.x communicator too.
This isn't particularly an image problem. Its more
of a page design problem. CSS would have done the
job more efficiently.
-pn

Updated

19 years ago
Status: RESOLVED → REOPENED

Comment 4

19 years ago
I'm re-opening this:

	* We're taking eight minutes and fifteen seconds to lay out this page.
(Yesterday's Win32 build on a 233 Mhz P2)

	* IE 5, running on the same system, does it in just the fifteen seconds. ;)

Reassigning to rickg. I assume this is just another duplicate of the "tables are
painfully slow", but would like to be sure.

Updated

19 years ago
Assignee: pnunn → karnaze
Status: REOPENED → NEW
Component: ImageLib → HTMLTables

Comment 5

19 years ago
Oops. Make that karnaze.

Updated

19 years ago
Resolution: INVALID → ---

Comment 6

19 years ago
Moving to m13 -- have a nice day.

Updated

19 years ago
Target Milestone: M12 → M13

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 7

19 years ago
Known issue of images without width/height tags

*** This bug has been marked as a duplicate of 17265 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
Verifying as duplicate. Clarified title in the other bug to make it easier for
people to find.
You need to log in before you can comment on or make changes to this bug.