Closed Bug 17265 Opened 20 years ago Closed 20 years ago

Displaying lots of images w/o WIDTH & HEIGHT tags is very slow

Categories

(Core :: Layout, defect, P3, major)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: mkaply, Assigned: nisheeth_mozilla)

References

()

Details

(Keywords: perf)

Loading this page hangs the current build.

Note that on 4.X with image loading turned off this page makes major memory
allocations. Not sure if they are related.
Status: NEW → ASSIGNED
Depends on: 11702
The page isn't hanging. It's just taking an enormously large amount of time,
best measured in lifetimes and not seconds.

The page has 40 images without width/height tags. That means we end up
generating 40 incremental reflow commands. That might not be so bad except that
they're all inside of a table and that means lots of reflow.

Marking as a PERF bug.

Note that the general table incremental reflow performance issue is covered by
bug #11702. This bug demonstrates the need for coalescing of reflow commands. If
we did that we would cut way down on the number of incremental reflows we
perform, because many of the images are the same
*** Bug 18363 has been marked as a duplicate of this bug. ***
*** Bug 16124 has been marked as a duplicate of this bug. ***
Summary: Hang loading web page → Displaying lots of images w/o WIDTH & HEIGHT tags is very slow
[clarified title so that folks can more easily find the bug]
Assignee: troy → nisheeth
Status: ASSIGNED → NEW
Seems to load better with the latest build, but this shows the need for reflow
command coalescing.
Setting milestone to M13 and accepting bug...
Status: NEW → ASSIGNED
Changing url because the earlier one's content got archived.  This new url
points to that archive.
Target Milestone: M13 → M15
Moving non-blockers for beta to M15...
Keywords: perf
Page loading on these pages is more bearable now.  Marking this bug WORKSFORME.

Note that we only do reflow command coalescing within block and inlines at this 
time so this bug is not helped by that work.  When we start coalescing within 
tables also, pages like these should load even faster.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Performance is better. Tested with the April 21 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.