Closed Bug 16125 Opened 21 years ago Closed 20 years ago

[FLASH] Drawing problems on Mac OS

Categories

(Core :: Plug-ins, defect, P3)

PowerPC
Mac System 9.x
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: elig, Assigned: serhunt)

References

()

Details

(Keywords: platform-parity)

Attachments

(3 files)

* TITLE/SUMMARY
[PP] [FLASH] Drawing problems on Mac OS & Linux

(broken out of bug #8063)

* STEPS TO REPRODUCE
0) Launch Apprunner
1) On Mac OS, install the Flash plug-in, 4.0 r14.
2) On Linux, install Flash Player 4, August 25th 1999
3) View these URLs:
	- http://www.geocities.com/tokyo/bay/9072/scaled.html
 - http://www.geocities.com/tokyo/bay/9072/fixed.html

* RESULT
 - What happened

Linux:
* No Flash content appears. Left-hand portion of page containing flash
content is black; no way to trigger events that I can discern.

Mac OS:
* Flash content not automatically redrawn when browser window covered up and
re-exposed.

* On the fixed.html page, the page content is drawn on top of the page
chrome. Also, upon a window resize, the plug-in output is replaced with a gray
rectangle. (Moving the mouse over the gray rectangle results in Flash content
appearing upon mouse-over over the appropriate locations.)


 - What was expected

Behavior on these pages equivalent to when viewed on Win32. (I used the 4.0r13
version of the Flash plug-in, NPSWF32.dll.)


* REGRESSION

 - Occurs On
        Mac OS Apprunner (1999 10/07 08:00)
        Linux Apprunner (1999 10/11 08:00)

 - Doesn't Occur On
        Win32 Apprunner (1999 10/6 08:00)


* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
Shrirang is now QA owner for Plug-ins; QA assigning all of my Plug-ins bugs over
to him.
Status: NEW → ASSIGNED
Target Milestone: M14
Keywords: pp
Target Milestone: M14 → M15
Summary: [PP] [FLASH] Drawing problems on Mac OS & Linux → [FLASH] Drawing problems on Mac OS & Linux
Flash plugins now works properly on mac. It won't work on Linux unless a mozilla 
compatible plugin is released by Shockwave. So marking this bug as worksforme.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Doesn't work for me.

On MozMacM14 (2000022108) OS 9, go to www.nin.com. There is an intro animation
(a flashing "NIN" logo) and then you are taken to the homepage (a Flash object
w/ multiple links). However, when the intro is loaded, only the left half
displays (the right half only shows up as a gray rectangle). The same happens
for the homepage. Using Macromedia Netscape Plugin: Shockwave Flash NP-PPC 4.0
r20. Might have to take another look at this one.
Re-opening for Shrirang & AV. Thanks!
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Akay,do you have the shockwave plugin file placed in the "Plugins" folder under   
your mozilla installation?
  
Whoops, didn't catch the ? - sorry. Yeah. At the time I had the latest Flash
plugin in the Moz Plugins folder. Tried with other plugins in the ? and with
just Flash. Also tried with r27. Will try with M15 (2000030508) sometime this
week.
Tried on Mozilla Mac M15 (2000030508) with latest Flash (4.0r27) plugin in the

Plugins folder in the Mozilla directory. The animation again failed to display

correctly (same problem) and Mozilla promptly crashed after the animation

finished loading. Interesting crash so I'm attaching a StdLog from MacsBug 6.6.

Target Milestone: M15 → M17
As Flash content is widely used on the internet, does anyone agree that this 
should be on the list for nsBeta2 (the Shockwave problems have already been 
added)?
Do you still have problems viewing flash movies on mac? I can get flash to work 
fine on macintosh builds. Pls try again. Thnx. Am changing summary for mac OS.
Summary: [FLASH] Drawing problems on Mac OS & Linux → [FLASH] Drawing problems on Mac OS
I'm stil seeing the gray rectangle upon resizing <http://www.broesewristers.nl>. 
Would be happy to do final Mac verification on this bug when it's fixed if you'd 
like.
Thanks eli !  setting qa contact :elig

bug 35777 exists for the resize problem .
QA Contact: shrir → elig
Will do in the next few days.

akay@mac.com, given your successes in making flash problems appear, please feel 
free to give it a whirl and add your thoughts.
I see this problem only at <http://www.nin.com/pgs/randomgrid.html>. I'll attach 
the page source so somebody can look at it and see if there's something besides 
Flash that's causing the problem. The SWF is at <http://www.nin.com/flp/
randomgrid.swf>. Other pages with Flash content loaded fine (although I noticed a 
problem where the animations would run, pause for a while, then run again, then 
pause, etc.).

If someone can look at the above URL and verify that a gray box does appear over 
the right half of the animation, I won't feel so stupid :)
Whoops. Also saw this at <http://www.macromedia.com/shockwave/welcome/>. Can't 
view page source from within Mozilla (I think Mozilla won't load the page source 
when there's data on the page handled by a plugin - I saw this at nin.com too and 
have seen it while testing QT plugin earlier this week). oddcast.com crashed (I 
tried three times) so I can't verify with that.
Keywords: flash
OS: Mac System 8.6 → Mac System 9.0
I believe this bug is too general (there's a variety of Flash problems that are 

either A) already filed in a different bug report or B) deserve their own 

attention/more/specific/new bug report. So, while playing with Flash, I'm going 

to dump my problems in here (a little like a bug grab bag) that can be later 

pulled out and filed in their own separate report (if they're found to be actual 

problems.



If this is bad, pls. let me know.

That said, Mozilla M16 2000042010, Mac OS 9.0.4

Everytime I load http://www.oddcast.com/, the page loads, the SWF loads and the 
content displays. However, somewhere between the intro animation and the display 
of the actual content of the page, I am routed to a page saying that I need to 
download the Flash player (after the Flash content has already loaded). Then, the 
browser crashes (hard - I have to restart). Attaching a StdLog of the oddcast 
crash. This is with the Flash 4.0r27 plugin that's included with the precompiled 
nightly binaries.
I agree that this bug should be closed out, and separate issues split into other 
bug reports.

The only problem in this bug report I can reproduce (using yesterday's Mozilla 
build, 4.0r27 Flash plug-in on Mac OS) is that the Flash animation <http://
www.macromedia.com/shockwave/welcome/> only displays (most of) the bottom third. 
The remainder of the animation is a grey box. 

Shrirang & Andrei: does an existing bug not already cover the root cause of this 
problem? If one doesn't, I'd be happy to split off a new bug report for it.
I'm closing out this bug report, per chat with shrirang, and Adam's comments.

* <http://www.macromedia.com/shockwave/welcome/> -> I see gray areas, but it 
otherwise looks okay. Split out into 37126.
* http://www.oddcast.com crash -> split out into 37145. CC'd akay.
Mac-specific stuff taken care of. Just have the NIN thing...
* NIN Flash animation's failure to procede beyond "Click Here" ---> bug #37162.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
To the best of my knowledge, every remaining issue in this bug report has been 
split out. I'm thus verifying it as fixed.

akay/et al, if there are additional issues that I've missed, please don't 
hesitate to file them as new bug reports in the 'Plug-ins' component.

Thanks!
Status: RESOLVED → VERIFIED
Looks like you got it all.

That's right, you the man! :)
OS: Mac System 9.x
You need to log in before you can comment on or make changes to this bug.