[FLASH] flash movie does not play as intended

VERIFIED FIXED in M11

Status

()

P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: freire, Assigned: serhunt)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
These are related to windows 95 testing of nglayout.
I have designed these flash-enabled pages,
and I suppose nglayout should have backward
compatibility, but it has not showed my pages
properly. the flash movies are supposed to
be scaled along with the browser window, and
they do behave like that in both netscape 4.6
and ie 5.0. But nglayout show them at a very small
size, unreadable. I changed the code to display
the movies on a fixed size, and they played well.
except for this: when the windows is resized to
be smaller than the movies, the scroolbars show up,
but if I scroll it sideways, or resize it to a
bigger size again, the background shows
white instead of the background color.
The page is under development, the flash buttons
do nothing but playing sounds, so I placed them in
my geocities site.
http://www.geocities.com/tokyo/bay/9072/scaled.html
for the scaled version
http://www.geocities.com/tokyo/bay/9072/fixed.html
for the (duh) fixed-size.
one more thing: the movies don't show transparent.
(in ie they do).
my nightly build dates from 08-june-99.
apprunner crashes on start, but viewer works.

Comment 1

20 years ago
Reassigning Plugin bugs to Andrei
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
Summary: flash movie does not play as intended → [FLASH] flash movie does not play as intended
Marked [FLASH].

Updated

19 years ago
Target Milestone: M10 → M11

Comment 3

19 years ago
m11
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
QA Contact: beppe → elig

Comment 4

19 years ago
Hey, Andrei ---

On the 1999100608 Win32 commercial build using the 4.0r13 NPSWF32.dll, this
works.

However, on Mac OS and Linux (both 1999100708), there are side-issues for which I
don't see bugs [querying subject "flash"]. Since I'm unfamiliar with this
component, could you possibly let me know whether these should be split into
separate bugs?

* Mac OS (4.0 r14 Shockwave Flash plug-in):
	- Flash content not automatically redrawn when browser window covered up and
re-exposed.
	- On the fixed.html page, the page content is drawn on top of the page
chrome. Also, upon a window resize, the plug-in output is replaced with a gray
rectangle. (Moving the mouse over the gray rectangle results in Flash content
appearing upon mouse-over over the appropriate locations.)

* Linux (Flash Player 4, August 25th 1999):
	* No flash content appears. Left-hand portion of page containing flash
content is black; no way to trigger events that I can discern.


Thanks!

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Verified fixed; broke issues from 10.7.99 comment into bug #16125, regarding
problems displaying these Flash-enabled pages, per av's request.
You need to log in before you can comment on or make changes to this bug.