Closed Bug 1615274 Opened 2 years ago Closed 2 years ago

Bodyfitplan website not rendered correctly in Print Preview

Categories

(Core :: Print Preview, defect)

Desktop
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 939897

People

(Reporter: vlucaci, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Bodyfitplan website.gif

Affected versions

  • 75.0a1(20200213035745)
  • 74.0b2(20200211200559)
  • 73.0(20200207195153)

Affected platforms

  • Windows 10x64
  • Ubuntu 18.04

Steps to reproduce

  1. Launch FF
  2. Go to https://bodyfitplan.me/final/?user_id=2359012.
  3. Go to burger menu.
  4. Go to "Print..." and click the option

Expected result

  • Page is successfully rendered in print preview, and all pages of the website are displayed.

Actual result

  • Page is not rendered correctly in print preview, as only the content of the first page is loaded.

Regression range

  • Will return with a regression ASAP.

Additional notes

  • This issue also occurs in Chrome, but to a much lesser extent:

  • I have managed to determine that the issue occurs in Chrome if the user does not scroll and load content prior to that.

  • Scrolling the webpage to load content in FF prior to entering Print Preview , makes no difference, as only the first page will be displayed.

Blocks: 1557682
No longer depends on: 1557682
See Also: → 534182

For what it's worth, I am seeing the same behavior in the MacOS print preview. I used mozregression to test a build from 2018-01-01 and saw the same behavior there.

I don't have a Windows or Linux machine at my disposal at this time, otherwise I would test those, too.

Has Regression Range: --- → no
Has STR: --- → yes

Regression range

Has Regression Range: no → yes

Pretty sure this is a dupe of bug 939897 which might also be affected by bug 1564128. The containing element (<div id="page">) is a flex container (so we don't fragment it's children properly), AND there is a page load animation (we always print animations from their initial state). I'm not sure why this is reproducible in Chrome; perhaps they have a similar bug around printing animations from their initial state.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
See Also: → 1564128
Duplicate of bug: 939897
Attached image Black print preview.gif

Hello Sean, I have also encountered something about the same as this, on icq.com. It seems that it is pretty intermittent. Sometimes the page is rendered and printed correctly, and sometimes all is black. I'll attach a screencast here. And this seems to happend only on landscape mode.

On a build back from February, the print pages seems to see only 1 page of 1, while on 74.0b5 it seems that it will see 16 pages. When those 16 pages are correctly rendered, they will be looking all the same (as page 1).

If you want me to post a new issue for this, please let me know.

Flags: needinfo?(svoisen)

Hi Catalin: Yes, that seems to be a separate issue. It's good to know we get all 16 pages, which is due to the fix from bug 1622935. But it's bad that they are all black! Please file a new bug.

Flags: needinfo?(svoisen) → needinfo?(catalin.sasca)

Ok Sean, done. Here's the new bug 1651654.

Flags: needinfo?(catalin.sasca)
You need to log in before you can comment on or make changes to this bug.