Closed Bug 1615714 Opened 10 months ago Closed 10 months ago

hiddenwindow errors on macOS with chat

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set
normal

Tracking

(thunderbird_esr68 unaffected, thunderbird74 fixed)

RESOLVED FIXED
Thunderbird 75.0
Tracking Status
thunderbird_esr68 --- unaffected
thunderbird74 --- fixed

People

(Reporter: rjl, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

Attached image image.png

I'm not able to connect to an IRC server with Thunderbird 74.0b1-build3.

The Developer tools console has errors referring to "hiddenwindow.jsm".

Same test on Linux worked.

Magnus / Florian, any idea what might be going on here?

Flags: needinfo?(mkmelin+mozilla)
Flags: needinfo?(florian)

Don't know why it would happen.
But maybe instead of the hiddenWindow.jsm getHiddenHTMLWindow should just be Services.appShell.createWindowlessBrowser()?

Flags: needinfo?(mkmelin+mozilla)

On first start to the normal three-pane window I see this message:

XML Parsing Error: undefined entity
Location: chrome://messenger/content/hiddenWindow.xhtml
Line Number 621, Column 15:

It points to:

              <menuitem id="calendar-new-event-menuitem"
                        label="&lightning.menupopup.new.event.label;"
                        accesskey="&lightning.menupopup.new.event.accesskey;"
                        key="calendar-new-event-key"
                        command="calendar_new_event_command"/>

and those calendar entries definitely aren't shown.

Rob, do you see this if you look earlier at startup?

I'm thinking that bug 1608610 probably didn't take account of affecting the hidden window when adding to mainNavigationToolbox.inc.xhtml.

Flags: needinfo?(rob)
Flags: needinfo?(philipp)
Attached patch bug1615714_mac_hiddenwin.patch (obsolete) — Splinter Review

Add missing dtds. Someone with a mac should check.

Yes that exact error.

(In reply to Mark Banner (:standard8) from comment #3)

On first start to the normal three-pane window I see this message:

XML Parsing Error: undefined entity
Location: chrome://messenger/content/hiddenWindow.xhtml
Line Number 621, Column 15:

It points to:

              <menuitem id="calendar-new-event-menuitem"
                        label="&lightning.menupopup.new.event.label;"
                        accesskey="&lightning.menupopup.new.event.accesskey;"
                        key="calendar-new-event-key"
                        command="calendar_new_event_command"/>

and those calendar entries definitely aren't shown.

Rob, do you see this if you look earlier at startup?

I'm thinking that bug 1608610 probably didn't take account of affecting the hidden window when adding to mainNavigationToolbox.inc.xhtml.

Flags: needinfo?(rob)
Attached image image2.png

I ran the build Magnus did on try withj this patch and I no longer get the hiddenWindow error. I was able to connect to an IRC server, but as soon as I joined a channel, Thunderbird crashed. Devtools stayed running though so I was able to get the screenshot.

Comment on attachment 9126977 [details] [diff] [review]
bug1615714_mac_hiddenwin.patch

Looks like still some entity missing. Khushil, can you check it out?
Attachment #9126977 - Flags: feedback?(khushil324)

I'm not 100% sure, but there might need to be some Javascript inclusions as well, so the menu options keep working when all other windows are closed.

Added the scripts.

Attached file crash.txt

Not sure if this is helpful or not?

Comment on attachment 9127079 [details] [diff] [review]
bug1615714_mac_hiddenwin.patch

Review of attachment 9127079 [details] [diff] [review]:
-----------------------------------------------------------------

It's working. IRC account is getting connected.
Attachment #9127079 - Flags: feedback+
Attachment #9126977 - Attachment is obsolete: true
Attachment #9126977 - Flags: feedback?(khushil324)
Attachment #9127079 - Flags: review?(paul)
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird 75.0
Keywords: regression
Regressed by: 1608610
Comment on attachment 9127079 [details] [diff] [review]
bug1615714_mac_hiddenwin.patch

Review of attachment 9127079 [details] [diff] [review]:
-----------------------------------------------------------------

Changes look good.  I don't have a mac so I can't test.  It would be worth adding comments to messenger.xhtml and hiddenWindow.xhtml saying that any changes to DTD and JS scripts need to be made in both places.  Or even better, put the common items in one or more include files and include them in both places (to avoid having to remember to make changes in two places).
Attachment #9127079 - Flags: review?(paul) → review+

Yeah we need to put more of these in includes.

Flags: needinfo?(philipp)
Flags: needinfo?(florian)

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9929fcef2872
fix hiddenwindow errors on macOS - include the scrips and dtds that are in messenger.xhtml. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Should we uplift this to beta?

Comment on attachment 9127079 [details] [diff] [review]
bug1615714_mac_hiddenwin.patch

Review of attachment 9127079 [details] [diff] [review]:
-----------------------------------------------------------------

We should
Attachment #9127079 - Flags: approval-comm-esr68+
Attachment #9127079 - Flags: approval-comm-esr68+ → approval-comm-beta+
Duplicate of this bug: 1618774
See Also: → 1626669
You need to log in before you can comment on or make changes to this bug.