Closed Bug 1616570 Opened 2 months ago Closed 1 month ago

Syncing CookieSettings to the WindowContext from Document.

Categories

(Core :: Privacy: Anti-Tracking, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla75
Fission Milestone M6
Tracking Status
firefox75 --- fixed

People

(Reporter: timhuang, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

Attachments

(4 files)

As part of the ETP-Fission work, we need to make the CookieSettings to be accessible through the browsingContext. So, we can access it across process boundaries.

Blocks: 1616775
No longer blocks: etp-fission
Duplicate of this bug: 1612350

Tracking for Fission Nightly (M6)

Fission Milestone: --- → M6

Given that we are going to add ContentBlockingAllowList in
CookieSettings, so CookieSettings will be responsible for more stuff than the
cookie behavior and cookie permission. We should use a proper name to
reflect the purpose of it. The name 'CookieSettings' is misleading that
this is only for cookie related stuff. So, we decide to rename
'CookieSettins' to 'CookieJarSettings' which serves better meaning here.

This patch adds a new field CookieJarSettings in the browsing context.
This makes the CookieJarSettings can be accssible across the process
boundaries, which is needed for the work of making the ETP
Fission-compatible.

Depends on D63935

This patch makes the cookie jar settings to be populated in the browsing
context. The cookie jar settings will be synced to the browsing context
as it has been set in the loadInfo.

Depends on D63937

Attachment #9128593 - Attachment description: Bug 1616570 - Part 3: Populate the cookie jar settings in the browsing context. r?Ehsan → Bug 1616570 - Part 3: Move the cookie jar settings to the browsing context. r?Ehsan

We don't need to create the blocking-all cookieJarSettings every time we
request it since it is basically the same. Instead, we should make it as
a singleton.

The patch makes this change the rename the
CookieJarSettings::CreateBlockingAll() to GetBlockingAll() which
reflects the fact that it is a singleton.

Depends on D63937

Attachment #9128593 - Attachment description: Bug 1616570 - Part 3: Move the cookie jar settings to the browsing context. r?Ehsan → Bug 1616570 - Part 4: Move the cookie jar settings to the browsing context. r?Ehsan
Summary: Making CookieSettings to be accessible through the browsingContext. → Moving CookieSettings to the WindowContext from Document.
Attachment #9128592 - Attachment description: Bug 1616570 - Part 2: Add the nsICookieJarSettings as a field in the browsing context. r?Ehsan,farre → Bug 1616570 - Part 2: Add the nsICookieJarSettings as a field in the window context. r?Ehsan,farre
Attachment #9128593 - Attachment description: Bug 1616570 - Part 4: Move the cookie jar settings to the browsing context. r?Ehsan → Bug 1616570 - Part 4: Sync the CookieBehavior of the CookieJarSettings into the WindowContext. r?Ehsan
Summary: Moving CookieSettings to the WindowContext from Document. → Syncing CookieSettings to the WindowContext from Document.
Attachment #9128592 - Attachment description: Bug 1616570 - Part 2: Add the nsICookieJarSettings as a field in the window context. r?Ehsan,farre → Bug 1616570 - Part 2: Add the CookieJarSettingsArgs as a field in the window context. r?Ehsan,farre
Attachment #9128592 - Attachment description: Bug 1616570 - Part 2: Add the CookieJarSettingsArgs as a field in the window context. r?Ehsan,farre → Bug 1616570 - Part 2: Add the nsICookieJarSettings as a field in the window context. r?Ehsan,farre
Attachment #9128592 - Attachment description: Bug 1616570 - Part 2: Add the nsICookieJarSettings as a field in the window context. r?Ehsan,farre → Bug 1616570 - Part 2: Add the CookieJarSettingsArgs as a field in the window context. r?Ehsan,farre
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7a18a0d2e114
Part 1: Rename CookieSettings to CookieJarSettings. r=Ehsan
https://hg.mozilla.org/integration/autoland/rev/3855ea76bc29
Part 2: Add the CookieJarSettingsArgs as a field in the window context. r=Ehsan,farre
https://hg.mozilla.org/integration/autoland/rev/1bad5855c84f
Part 3: Change the CookieJarSettings::CreateBlockingAll to be a singleton and rename it to GetBlockingAll(). r=Ehsan
https://hg.mozilla.org/integration/autoland/rev/073bf81ba3cd
Part 4: Sync the CookieBehavior of the CookieJarSettings into the WindowContext. r=Ehsan
You need to log in before you can comment on or make changes to this bug.