Closed Bug 1616700 Opened 1 year ago Closed 2 months ago

Use the default address bar search mode for new tab search handoff

Categories

(Firefox :: Address Bar, enhancement, P3)

enhancement
Points:
3

Tracking

()

VERIFIED FIXED
89 Branch
Iteration:
88.2 - Mar 8 - Mar 21
Tracking Status
firefox89 --- verified

People

(Reporter: verdi, Assigned: harry)

References

(Blocks 4 open bugs, Regressed 1 open bug)

Details

(Keywords: blocked-ux, Whiteboard: [proton-address-bar] )

Attachments

(3 files)

Currently in Nightly if I type in the new tab/home page search bar, my query is moved to the address bar and prefixed with @google (if my default search engine is google). This limits me to only receiving search suggestions. While that is the same experience as the new tab search bar, we should give people the full benefit of receiving both search and history suggestions that you'd normally get in the address bar. Therefore, please stop prefixing searches handed off from the new tab search bar.

Priority: -- → P3
Blocks: 1552463
Points: --- → 3

If we resolve this, let's do it as a pref. Given that newtab's major competition comes from search engines, it may make sense to provide a more limited default experience here.

There is one downside in doing this. If the user disabled search suggestions, in search mode we will still provide them, but if we instead enter normal mode, the user won't get suggestions.

Flags: needinfo?(mverdi)
Severity: normal → N/A
Summary: Use default address bar search mode for new tab search handoff → Evaluate using default address bar search mode for new tab search handoff
Whiteboard: [proton-address-bar]
Blocks: 1645293
Keywords: blocked-ux
Blocks: 1344931

(In reply to Marco Bonardo [:mak] from comment #2)

There is one downside in doing this. If the user disabled search suggestions, in search mode we will still provide them, but if we instead enter normal mode, the user won't get suggestions.

Yeah - it's like we've removed the new tab search bar and put the address bar in the page. Expected but we should be aware that this is a change for some people. We should update the prefs to match the functionality.

Flags: needinfo?(mverdi)
Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 88.2 - Mar 8 - Mar 21

This behaviour is not behind a Proton pref because handoff is only preffed on in Nightly and it would significantly complicate post-Proton cleanup.

Attachment #9208797 - Attachment description: Bug 1616700 - Use default address bar search mode for new tab search handoff and update new tab search placeholder text. → Bug 1616700 - Part 3 - Update the placeholder string on the handoff input to read "Search with {engine} or enter address"
Summary: Evaluate using default address bar search mode for new tab search handoff → Use the default address bar search mode for new tab search handoff
Blocks: 1699834
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/de3717cc63ef
Part 1 - Use default address bar search mode for new tab search handoff r=Standard8
https://hg.mozilla.org/integration/autoland/rev/fdf97a561019
Part 2 - Apply a disabled appearance to the handed-off input rather than hiding it. r=Standard8
https://hg.mozilla.org/integration/autoland/rev/5e1b8f75fef5
Part 3 - Update the placeholder string on the handoff input to read "Search with {engine} or enter address" r=fluent-reviewers,Standard8

Backed out 3 changesets (Bug 1616700) for causing failures in browser_privatebrowsing_about.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/60a5722f27ee5f00aa610a1874994b894d66c5ce
Push with failures, failure log.

Flags: needinfo?(htwyford)
Regressions: 1699840
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7415db8cd0fb
Part 1 - Use default address bar search mode for new tab search handoff r=Standard8
https://hg.mozilla.org/integration/autoland/rev/69900b283aa4
Part 2 - Apply a disabled appearance to the handed-off input rather than hiding it. r=Standard8
https://hg.mozilla.org/integration/autoland/rev/3aba8daf43c2
Part 3 - Update the placeholder string on the handoff input to read "Search with {engine} or enter address" r=fluent-reviewers,Standard8
Regressions: 1700527
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

verified fix on Firefox nightly 89.0a1 using windows10 64bit , macos 10.15 and ubuntu 20 64bit

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.