Closed Bug 1616880 Opened 10 months ago Closed 9 months ago

Make tab navigation work when there's a search string

Categories

(Firefox :: Address Bar, enhancement, P1)

Desktop
All
enhancement
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 75
Iteration:
75.1 - Feb 10 - Feb 23
Tracking Status
firefox73 --- unaffected
firefox74 --- verified
firefox75 --- verified

People

(Reporter: mak, Assigned: mak)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Verdi said we should re-enable tab navigation when there is a typed search string, mouse will still always allow to navigate with tab.
This means pretty much only top sites (shown when there's no typed string, or with the current page url) can't be navigated with tab.
We can also remove the pref disabling keyboard tab navigation, since it would only affect this tiny case.

There is one case we would like to be sure about, for a11y:

  1. type a string
  2. unfocus the urlbar
  3. focus the urlbar again through the keyboard shortcut
  4. at this point we reopen the view, and because there is a typed string tab would go through results

Jamie, does that look ok?

Sorry, I forgot the needinfo, please see comment 0.

Points: --- → 2
Flags: needinfo?(jteh)
Blocks: urlbar-update-1
No longer blocks: 1616872
Depends on: 1608766

Eek, that is indeed a bit ugly. However, I think it's mitigated by two things:

  1. It's probably rare that a user will unfocus the URL bar after typing.
  2. Unfocusing the URL bar would most often be done with tab or shift+tab, but since tab will move through results (as it did previously), the user will need to clear the address bar first in order to unfocus it this way (as was the case previously).

So, I think this should be okay. Certainly, I think it's a better compromise for different groups of users than we have now.

Flags: needinfo?(jteh)

(In reply to James Teh [:Jamie] from comment #2)

  1. Unfocusing the URL bar would most often be done with tab or shift+tab, but since tab will move through results (as it did previously), the user will need to clear the address bar first in order to unfocus it this way (as was the case previously).

Note currently tabbing out and back in the urlbar doesn't reopen the view, but it should and that's bug 1616872. So yes, once that will be fixed, you'll have to clear the string to tab away from the urlbar.

See Also: → 1613894
Assignee: nobody → mak
Status: NEW → ASSIGNED

:mak, it's unclear for QA if this will be uplift material for 74?

Flags: needinfo?(mak)

yes, it should be in 74.

Flags: needinfo?(mak)
Duplicate of this bug: 1617439
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/b8b8bd8165bd
Allow tabbing through urlbar results when there's a search string. r=adw
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75

Comment on attachment 9128180 [details]
Bug 1616880 - Allow tabbing through urlbar results when there's a search string. r=dao,adw

Beta/Release Uplift Approval Request

  • User impact if declined: We would like to run a pref flipping experiment in Firefox 74 with the new design enabled, this is part of it.
    The new design is normally disabled in 74, and will ride the train for 75.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Open a new tab, the urlbar should be focused, press tab, focus should move to the next toolbar item.
    Open a new tab, the urlbar should be focused, type something in the urlbar, press tab, focus should move to the next urlbar result.
    Focusing the urlbar with the mouse should always tab through results.
    focusing the urlbar with the keyboard shortcut (CTRL+L) should tab through results if there's a user types string, focus the next toolbar item otherwise.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The new design will be disabled by default in Firefox 74, it will only affect our pref-flip experiment.
    This also moves use closer to the old behavior.
  • String changes made/needed:
Attachment #9128180 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9128180 [details]
Bug 1616880 - Allow tabbing through urlbar results when there's a search string. r=dao,adw

Needed for a 74 study, uplift approved for 74.0b8, thanks.

Attachment #9128180 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Iteration: --- → 75.1 - Feb 10 - Feb 23
QA Whiteboard: [qa-triaged]
Duplicate of this bug: 1618381

Verified the fix in Nightly 75.0a1 - 2020-02-28 on Windows 10 / Ubuntu 18.04 / Mac 10.13
Verified the uplift in 74.0b9 - 2020-02-27 on Windows 10 / Ubuntu 18.04 / Mac 10.13 (browser.urlbar.update1 - true ; browser.urlbar.openViewOnFocus - false )

The verification was focused on being able to use Tab to be able to navigate through the results, while there is user input or search results, in other cases it would navigate to the next toolbar item (next toolbar item being the Library as default). I could only see one problem (bug 1618250 ) which was already logged with additional investigation noted, bug being only visible when browser.urlbar.openViewOnFocus is true (preference false by default on beta).

Note:
Normally, since QuantumBar is pref'ed of in 74, I would mark 74 as disabled, but since this fix was uplifted with 74 study toggle in mind, I'm going to mark it as verified in this case.

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
OS: Unspecified → All
Hardware: Unspecified → Desktop
Status: RESOLVED → VERIFIED
Type: task → enhancement
See Also: → 1666927
You need to log in before you can comment on or make changes to this bug.