Closed Bug 1617095 Opened 5 months ago Closed 5 months ago

"mach bootstrap" fails with "TypeError: 'odict_items' object does not support indexing"

Categories

(Firefox Build System :: Bootstrap Configuration, defect)

defect
Not set
normal

Tracking

(firefox-esr68 unaffected, firefox73 unaffected, firefox74 unaffected, firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- unaffected
firefox75 --- fixed

People

(Reporter: heycam, Assigned: emilio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

I can't run mach bootstrap on my Mac currently:

$ ./mach bootstrap
[...]
Please choose the version of Firefox you want to build:
  1. Firefox for Desktop Artifact Mode
  2. Firefox for Desktop
  3. GeckoView/Firefox for Android Artifact Mode
  4. GeckoView/Firefox for Android
Your choice: 2
Error running mach:

    ['bootstrap']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

TypeError: 'odict_items' object does not support indexing

  File "/z/moz/central/python/mozboot/mozboot/mach_commands.py", line 44, in bootstrap
    bootstrapper.bootstrap()
  File "/z/moz/central/python/mozboot/mozboot/bootstrap.py", line 410, in bootstrap
    name, application = APPLICATIONS.items()[prompt_choice-1]

Seems like bug 1614518 regressed this. (I hit this because I was trying to check out the new mach commands).

Flags: needinfo?(sphink)
Regressed by: 1614518

Doesn't run on Windows either, and since this is required to install Node 10 ... :-(

Same on Linux.

Blocks: mach-busted
Assignee: nobody → emilio
Status: NEW → ASSIGNED
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/mozilla-central/rev/793e3b87db82
Fix mach bootstrap interactive mode with python 3. r=froydnj a=Aryx
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

Wow, thanks, Emilio!

Flags: needinfo?(sphink)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/05f206719d98
Fix mach bootstrap interactive mode with python 3. r=froydnj

Whoa, I don't know how I missed seeing this. I was testing that path with every change up until very recently... :-(

You need to log in before you can comment on or make changes to this bug.