Closed Bug 1617730 Opened 4 years ago Closed 7 months ago

Crash in [@ gfxAlphaBoxBlur::DoBlur]

Categories

(Core :: Graphics, defect, P3)

74 Branch
x86
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- fix-optional
firefox75 --- ?

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [tbird crash])

Crash Data

This bug is for crash report bp-4aa1bf54-9bb4-4ff7-8b99-4d1930200222.

Top 10 frames of crashing thread:

0 xul.dll gfxAlphaBoxBlur::DoBlur gfx/thebes/gfxBlur.cpp:158
1 xul.dll static gfxAlphaBoxBlur::BlurRectangle gfx/thebes/gfxBlur.cpp:894
2 xul.dll static nsContextBoxBlur::BlurRectangle layout/painting/nsCSSRendering.cpp:4793
3 xul.dll static nsCSSRendering::PaintBoxShadowOuter layout/painting/nsCSSRendering.cpp:1609
4 xul.dll nsDisplayBoxShadowOuter::Paint layout/painting/nsDisplayList.cpp:5726
5 xul.dll mozilla::FrameLayerBuilder::PaintItems layout/painting/FrameLayerBuilder.cpp:7122
6 xul.dll static mozilla::FrameLayerBuilder::DrawPaintedLayer layout/painting/FrameLayerBuilder.cpp:7265
7 xul.dll mozilla::layers::ClientPaintedLayer::RenderLayerWithReadback gfx/layers/client/ClientPaintedLayer.cpp
8 xul.dll mozilla::layers::ClientContainerLayer::RenderLayer gfx/layers/client/ClientContainerLayer.h:53
9 xul.dll mozilla::layers::ClientLayer::RenderLayerWithReadback gfx/layers/client/ClientLayerManager.h:362

this crash signature is not new per se but it's starting to occur more regularly in firefox 74.0b. it's a content crash hitting only users on 32bit windows 10 so far, but there are no clear correlations or indications in the reports of what might have regressed it.

Depends on: 1619317
Priority: -- → P3
Severity: normal → S3

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.