Closed Bug 1618417 Opened 2 years ago Closed 2 years ago

Merge Initiator column into Cause

Categories

(DevTools :: Netmonitor, enhancement, P3)

enhancement

Tracking

(firefox77 fixed)

RESOLVED FIXED
Firefox 77
Tracking Status
firefox77 --- fixed

People

(Reporter: Harald, Assigned: transfusion)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Follow up from bug 1592535, which landed the stack trace as a new column. Meanwhile, more bugs and comments came in on the space and resizing limitations of the network table; which prompted us to revisit our existing columns but also the solution of adding a new column.

The last decision from the UX discussion is to merge the Initiator with the Cause column; while giving the stack trace more prominence:

With stack: location.js:line:column (cause)
Without stack: cause

Related discussions:
https://github.com/firefox-devtools/ux/issues/87
https://github.com/firefox-devtools/ux/issues/117

Before I mark this a good first bug: Transfusion, would you be interested in working on this?

Flags: needinfo?(bryan.wyern1)

Yes, please do assign me!

Flags: needinfo?(bryan.wyern1)
Assignee: nobody → bryan.wyern1
Status: NEW → ASSIGNED
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ca155a8aaeb7
Merge Initiator column into Cause r=Honza
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
You need to log in before you can comment on or make changes to this bug.