Incorrect caret positioning in text fields with zooming

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
major
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Erick Wong, Assigned: kinmoz)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.1b) Gecko/20020808
BuildID:    2002080811

There is a discrepancy between the position of the caret displayed in a text
field and where typed letters actually go.  As a result, it becomes impossible
to aim for a particular letter in a text field.  I can consistently reproduce
this behaviour using text zooming, but it seems to occur sporadically without
any zoom.  Once it starts, the problem is persistent.

Reproducible: Always
Steps to Reproduce:
1. Go to a web page with a one-line text field such as Google.
2. Press Cmd-+ to magnify the text zoom level.
3. Type in a long string of letters into the text field.
4. Experiment with different text zoom levels.

Actual Results:  After one text enlargement, the caret appears significantly
farther to the right than the text itself.  With two text enlargements, the
caret is lined up properly again.  At four enlargements, there is a small but
noticeable discrepancy.

I browse at 12 pt, so you may need to use different zoom levels to reproduce. 
The font used in the text field is Geneva.

Expected Results:  Caret should remain consistent with the positions of the letters.

Comment 1

16 years ago
probably related to bug 161818, but can occur in Western encodings.
Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Incorrect caret positioning in text fields → Incorrect caret positioning in text fields withzooming

Comment 2

16 years ago
bug 161878 may be related to this.

Comment 3

16 years ago
Does this only happen on Mac?

Comment 4

16 years ago
WFM 20020818 trunk 1.1RC for MacOS9.x.
I can not reproduce this in the latest build, either with fixed-width font (in
this field) or proportional font (Summary Field).
Summary: Incorrect caret positioning in text fields withzooming → Incorrect caret positioning in text fields with zooming
(Reporter)

Comment 5

16 years ago
I can't reproduce it either, and haven't seen it sporadically in limited use of
build 2002081717.  It sounds like the fix for bug 161818 might have killed this
bird, too?

Comment 6

16 years ago
-->
Assignee: rods → kin

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 7

15 years ago
This bug is targeted at a Mac classic platform/OS, which is no longer supported
by mozilla.org. Please re-target it to another platform/OS if this bug applies
there as well or resolve this bug.

I will resolve this bug as WONTFIX in four weeks if no action has been taken.
To filter this and similar messages out, please filter for "mac_cla_reorg".

Updated

15 years ago
OS: Mac System 9.x → MacOS X

Comment 8

15 years ago
Using bulid 200331120105 I can still confirm this bug using Macosx, try typing
this(all what I wrote) text for example in addditional comments text field, you
will notice that the caret will get  crazy. Moreover,  try to change the carot
position using mouse, it's imposibble.
WFM
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051001
Firefox/1.6a1 ID:2005100107

I'm marking this WORKSFORME based on comments #4 and #5, my own experience, and
the lack of duplicates/votes.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.