Removing parent of focused element kills focus

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: aduffy, Assigned: bryner)

Tracking

(Blocks: 1 bug, {sec508})

Trunk
sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607
BuildID:    mozilla 1.0

On the MSNBC.com webpage there is an area just to the right of the MSNBC logo
that automatically cycles through several current news items. This cycling is
done via Javascript. If the TAB key is used to set focus on this area, the
keyboard locks up. The TAB, shift-TAB, and up/down/left/right arrow keys used
for scrolling stop working.

Reproducible: Always
Steps to Reproduce:
1.Navigate to MSNBC.com
2.Observe that the area to the right of the MSNBC logo is cycling through
items.If not cycling, try again later. There is no problem if there is only one
item, or if the items are not links.
3.Let the mouse hover over the area to ensure that the item is really a link and
not just information.
4.Move the mouse away from the area. The cycling stops while the mouse is
hovering there.
5.Use the TAB key to shift focus to the area.
6.Once focus is on the area, the TAB, shift-TAB,and arrow keys stop functioning.


Actual Results:  The keyboard freezes.

Expected Results:  The keyboard should still be fucntioning.

Comment 1

16 years ago
Created attachment 94735 [details]
testcase

This testcase isn't based on msnbc, but I think it's the same problem. 
Removing the focused link from the document is fine, but removing the focused
link's container from the document causes almost all keyboard shortcuts to stop
working.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Summary: Putting focus on a link being modified by Javascript freezes keyboard. → Removing parent of focused element kills focus

Comment 2

16 years ago
-> bryner, focus bug (keyboard locks up) 
Assignee: aaronl → bryner
Blocks: 83552
Keywords: nsbeta1, sec508

Comment 3

16 years ago
Brian, I would consider this one important since it happens on a common page and
the keyboard gets totally hosed.

It's probably broken because once again, prseshell can't find a frame to send
the keyboard event to.
OS: Linux → All
Hardware: PC → All

Comment 4

16 years ago
adt: need info.  Aaron, et. al., does this affect multiple top sites?
Whiteboard: [need info]

Comment 5

16 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [need info]

Comment 6

16 years ago
WORKSFORME

Reporter, are you still experiencing the problem?

I don't see any cycling material on MSNBC at the moment, but the testcase is
working for me -- both in the trunk and in 1.4.
(Reporter)

Comment 7

16 years ago
Aaron

I just tried the MSNBC test using Mozilla 1.3.1 in Linux. The keyboard does NOT 
freeze up after shifting focus to the cycling item on the page. TAB, shift-TAB 
and the arrow keys seem to work OK.

Pressing "Enter" with focus on the cycling item does nothing. Clicking on the 
item with the mouse causes the page associates with the cycling news item to 
load OK.

Al


Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.