Closed Bug 1619258 Opened 1 month ago Closed 14 days ago

[Wayland] Implement vp9 VA-API decode by ffmpeg

Categories

(Core :: Audio/Video: Playback, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox75 --- wontfix
firefox76 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Implement HW decode of VP9 format by VA-API. Also check if that's faster than SW decode.

Assignee: nobody → stransky
Status: NEW → ASSIGNED

Jean, I'd like to go with this simplified version of vp9 HW support and implement the in-tree ffmpeg enhancement in a different bug.

Pushed by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/25fd7f65b469
[Wayland] Enable VA-API for all formats, r=jya
Status: ASSIGNED → RESOLVED
Closed: 14 days ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Depends on: 1623584

is any chance that this patch squeeze into mozilla75 ?

Since it's disabled by default and h264 only VAAPI can be lightly confusing for these who enable experimental VA-API support (and try youtube without h264ify plugin), backporting this patch could speed-up testing process of this feature.

https://nightly.mozilla.org should be used for VAAPI testing as there are still other VAAPI, WebRender and Wayland bugs.

Thanks, of course! Compiling _beta5 with cherry-picked deferencing fix and VP9 VA-API. I'll report how well it (does/doesn't) work :)

For h264 is it enough, but for VP9 probably some patch must be missing. I'm having these two patches applied:

Bug 1619258 [Wayland] Enable VA-API for all formats, r=jya
Bug 1622729 - Use the appropriate level of indirection when calling av_freep in FFmpegVideoDecoder. r=jya

For vp9 you need to disable media.ffvpx.enabled temporarily (bug 1623584 comment 20). If it does not work with https://nightly.mozilla.org, please see bug 1610199 comment 45.

Comment on attachment 9131132 [details]
Bug 1619258 [Wayland] Enable VA-API for all formats, r?jya

Beta/Release Uplift Approval Request

  • User impact if declined: va-api will support h264 decoding only.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Linux/Wayland only. Just removes a restriction we had for initial implementation. Functionality was confirmed by users (https://bugzilla.mozilla.org/show_bug.cgi?id=1623584#c21)
  • String changes made/needed: none
Attachment #9131132 - Flags: approval-mozilla-beta?
Depends on: 1623899

Comment on attachment 9131132 [details]
Bug 1619258 [Wayland] Enable VA-API for all formats, r?jya

This looks like something that should ride the trains.

Attachment #9131132 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.