Closed Bug 1619861 Opened 3 months ago Closed 2 months ago

Crash in [@ mozilla::dom::HTMLMediaElement::MediaControlEventListener::InitMediaAgent]

Categories

(Core :: Audio/Video: Playback, defect, P1)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gsvelto, Assigned: alwu)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-38f51b1b-14fa-4b1d-bdfc-749020200229.

Top 10 frames of crashing thread:

0 XUL mozilla::dom::HTMLMediaElement::MediaControlEventListener::InitMediaAgent dom/html/HTMLMediaElement.cpp:479
1 XUL mozilla::dom::HTMLMediaElement::MediaControlEventListener::Start dom/html/HTMLMediaElement.cpp:406
2 XUL mozilla::dom::HTMLMediaElement::SuspendOrResumeElement dom/html/HTMLMediaElement.cpp:6556
3 XUL mozilla::dom::HTMLMediaElement::NotifyOwnerDocumentActivityChanged dom/html/HTMLMediaElement.cpp:6589
4 XUL mozilla::dom::NotifyActivityChanged dom/base/Document.cpp:6797
5 XUL mozilla::dom::Document::EnumerateActivityObservers dom/base/Document.cpp:11903
6 XUL mozilla::dom::Document::UpdateVisibilityState dom/base/Document.cpp:14044
7 XUL mozilla::dom::Document::OnPageShow dom/base/Document.cpp:10781
8 XUL nsDocumentViewer::LoadComplete layout/base/nsDocumentViewer.cpp:1181
9 XUL nsDocShell::EndPageLoad docshell/base/nsDocShell.cpp:6084

NULL-pointer dereference happening on all platforms. This seems to have started with build id 20200226092757.

Target the fix on this cycle, mark this bug as P1.

Assignee: nobody → alwu
Priority: -- → P1

I think this crash is caused by bug1535617, but has been fixed by bug1618717, which has been landed on 2/28.

From the all reports, I didn't find any crash report using the build late than 2/28, so I think the crash has been fixed on the latest Nightly and I would close this bug.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.