Closed Bug 1620417 Opened 2 years ago Closed 2 years ago

Remove RDM tests that test tunnel, swap, or frame scripts

Categories

(DevTools :: Responsive Design Mode, task, P3)

task

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: bradwerth, Assigned: mtigley)

References

Details

Attachments

(1 file)

There are a class of tests that rely on features of the old RDM UI, which uses a tunnel and swap mechanism, and loads frame scripts in the browser iframe to support that. These tests generally are testing features that work in the regular browser and needed to be tested in a different way with the old RDM UI. With the new RDM UI, the existing tests for those features should cover the RDM usages also.

All of these tests should be removed. The list is, at least:

browser_contextual_identity.js
browser_favicon.js
browser_frame_script_active.js
browser_hide_container.js
browser_prompts.js

See Also: → 1620421
Assignee: nobody → mtigley
Status: NEW → ASSIGNED
Priority: -- → P3
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3bdc96cfe1e6
Remove RDM tests that test tunnel, swap, or frame scripts r=bradwerth
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Duplicate of this bug: 1585437
You need to log in before you can comment on or make changes to this bug.