Closed Bug 1620434 Opened 2 years ago Closed 2 years ago

flexible space is too narrow in the navbar in customize mode

Categories

(Firefox :: Toolbars and Customization, defect, P1)

74 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox73 --- unaffected
firefox74 --- wontfix
firefox75 --- verified
firefox76 --- verified

People

(Reporter: danielboontje, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

add spacers to the left of the "previous page" button (left of URL bar)

Actual results:

tiny spacers appear in customization-view.

Expected results:

should appear just as wide in customization-view as they appear in bookmark-bar.

Attached image Customize_spaces .png

I was able to reproduce this issue on latest Nightly version 75.0a1 (2020-03-09) on Windows 10. I attached a file and changed the component accordingly.

Component: Untriaged → Toolbars and Customization
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: regression
Regressed by: 1615767
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Priority: -- → P1
Summary: flexible space appearing wrong left of back button → flexible space is too narrow in the navbar in customize mode

final beta builds for 74 have been built so a fix here won't make 74.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/adffa9dc4864
increase default sizing of the spacers in the navbar in customize mode again, r=dao
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

The patch landed in nightly and beta is affected.
:Gijs, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(gijskruitbosch+bugs)

Comment on attachment 9132018 [details]
Bug 1620434 - increase default sizing of the spacers in the navbar in customize mode again, r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: Spacer sizing is off in the navbar in customize mode
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small CSS fix to make spacer sizing more sane/obvious
  • String changes made/needed: nope
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #9132018 - Flags: approval-mozilla-beta?

Comment on attachment 9132018 [details]
Bug 1620434 - increase default sizing of the spacers in the navbar in customize mode again, r?dao

approved for 75.0b3

Attachment #9132018 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I managed to reproduce the issue using an older version of Nightly from 2020-03-05 on Windows 10 x64.
I retested everything using latest Nightly 76.0a1 and beta 75.0b3 on Windows 10 x64, macOS 10.15 and Ubuntu 16.04 x64. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.